Bug #78892 [Opn->Dup]: php-fpm: 7.4.0 chown() the socket Operation not permitted
| From: | cmb@php.net | Date: | Sat, 30 Nov 2019 13:38:19 +0000 |
| Subject: | Bug #78892 [Opn->Dup]: php-fpm: 7.4.0 chown() the socket Operation not permitted | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-223966@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=78892&edit=1
ID: 78892
Updated by: cmb@php.net
Reported by: ilya at ilya dot pp dot ua
Summary: php-fpm: 7.4.0 chown() the socket Operation not
permitted
-Status: Open
+Status: Duplicate
Type: Bug
Package: *Configuration Issues
Operating System: openSUSE Tumbleweed
PHP Version: 7.4.0
-Assigned To:
+Assigned To: cmb
Block user comment: N
Private report: N
New Comment:
Duplicate of bug #78889.
Previous Comments:
------------------------------------------------------------------------
[2019-11-30 13:31:21] ilya at ilya dot pp dot ua
Description:
------------
After upgrade to 7.4.0
listen = /run/php-fpm.sock
listen.owner = nginx
listen.group = nginx
listen.mode = 0600
ERROR: [pool php] failed to chown() the socket '/run/php-fpm.sock': Operation not
permitted (1)
work only
listen = /run/php-fpm.sock
;listen.owner = nginx
;listen.group = nginx
listen.mode = 0666
Why it happens?
ArchLinux has the same problem.
https://bugs.archlinux.org/task/64683
Test script:
---------------
php-fpm:
listen = /run/php-fpm.sock
listen.owner = nginx
listen.group = nginx
listen.mode = 0600
Expected result:
----------------
Started The PHP FastCGI Process Manager
Actual result:
--------------
Starting The PHP FastCGI Process Manager...
ERROR: [pool php] failed to chown() the socket '/run/php-fpm.sock': Operation not
permitted (1)
ERROR: FPM initialization failed
Main process exited, code=exited, status=78/CONFIG
php-fpm.service: Failed with result 'exit-code'.
Failed to start The PHP FastCGI Process Manager.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=78892&edit=1