#19937 [NEW]: dynamic extension loading fails
| From: | ryan dot smith at openwave dot com | Date: | Wed, 16 Oct 2002 17:25:51 +0000 |
| Subject: | #19937 [NEW]: dynamic extension loading fails | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-22590@lists.php.net to get a copy of this message | ||
From: ryan.smith@openwave.com
Operating system: AIX 5.1
PHP version: 4.2.3
PHP Bug Type: Dynamic loading
Bug description: dynamic extension loading fails
Attempting to dynamically load a module fails under AIX. The error message
is:
PHP Warning: Unable to load dynamic library
'/usr/HTTPServer/libexec/firstmod.so' - Invalid argument in Unknown on
line 0
This indicates that the failure occurs during the DL_LOAD.
The module does exist, and can be loaded with dlopen() in a test program.
PHP is being loaded as a dynamic module within the IBM HTTP server (based
on Apache 1.3.12).
PHP was configured with:
CC='cc_r' \
CXX='xlC_r -E' \
'./configure' \
'--enable-c9x-inline' \
'--enable-shared' \
'--with-apxs=/usr/HTTPServer/bin/apxs' \
'--without-mysql' \
'--with-ldap=/users/rysmith/apache/openldap-2.0.25_AIX'
I've tried compiling the module in many ways:
(Simple)
cc -c test2.c
cc -G -o firstmod.so test2.o
(from sample IBM DSO makefile)
xlC_r -c -I /users/rysmith/apache/php-4.2.3/Zend -I
/users/rysmith/apache/php-4.2.3 -I/users/rysmith/apache/php-4.2.3/main
-I/users/rysmith/apache/php-4.2.3/TSRM -DAIX=42 -U__STR__
-DAIX_BIND_PROCESSOR -DUSE_HSREGEX -O2 -DSHARED_MODULE firstmod.c && mv
firstmod.o firstmod.lo
ld -H512 -T512 -bhalt:4 -bM:SRE -bnoentry
-bI:/users/rysmith/apache/php-4.2.3/ext/ryan/libphp4.exp -bE:`echo
firstmod.so|sed -e 's:\.so$:.exp:'` -lc -o firstmod.so firstmod.lo
Attempting to load the module from within a PHP script also fails in the
same way.
--
Edit bug report at http://bugs.php.net/?id=19937&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=19937&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=19937&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=19937&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=19937&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=19937&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=19937&r=support
Expected behavior: http://bugs.php.net/fix.php?id=19937&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=19937&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=19937&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=19937&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=19937&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=19937&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=19937&r=isapi