#19937 [Fbk->Opn]: dynamic extension loading fails

From: Date: Mon, 21 Oct 2002 15:28:01 +0000
Subject: #19937 [Fbk->Opn]: dynamic extension loading fails
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-22975@lists.php.net to get a copy of this message
ID: 19937 User updated by: ryan.smith@openwave.com Reported By: ryan.smith@openwave.com -Status: Feedback +Status: Open Bug Type: Dynamic loading Operating System: AIX 5.1 PHP Version: 4.3.0-dev New Comment: By specifying an extension path and then the extension: extension_dir=/usr/HTTPServer/libexec extension=libldap.so If you (or anyone) has a PHP setup that does demonstrate that this functionality works, I'd like to know. Previous Comments: ------------------------------------------------------------------------ [2002-10-19 10:48:08] sniper@php.net How exactly did you configure the loading of the extension in php.ini ? ------------------------------------------------------------------------ [2002-10-18 17:53:48] ryan.smith@openwave.com I just tried the latest snapshot, and it fails in the same way. Note that I am using the ldap extension to test this, so my configuration differs slight - it has --with-ldap=shared,/users/rysmith/apache/openldap-2.0.25_AIX ------------------------------------------------------------------------ [2002-10-18 16:47:17] sniper@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-10-18 16:35:08] ryan.smith@openwave.com No, the libphp4.so loads fine into apache. It's the PHP extensions which PHP loads, which do not load. For example, ldap. Or the sample module in the documentation. I set CC and CXX so that I use the IBM compiler and not gcc. (Although if I try with gcc, I get a core dump when the extensions load). ------------------------------------------------------------------------ [2002-10-18 16:25:14] sniper@php.net Exactly which module doesn't load? libphp4.so into apache? Or some shared extension into PHP? And why do you set 'CC' and 'CXX' before running configure? Why do you pass configure '--enable-shared' ?? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19937 -- Edit this bug report at http://bugs.php.net/?id=19937&edit=1

« previous php.bugs (#22975) next »