Bug #79550 [NEW]: Reloading the httpd service repeatedly causes a memory corruption error.

From: Date: Fri, 01 May 2020 07:33:59 +0000
Subject: Bug #79550 [NEW]: Reloading the httpd service repeatedly causes a memory corruption error.
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-226866@lists.php.net to get a copy of this message
From:             kitagawa at sraoss dot co dot jp
Operating system: Linux
PHP version:      7.3.17
Package:          Apache2 related
Bug Type:         Bug
Bug description:Reloading the httpd service repeatedly causes a memory corruption error.

Description:
------------
Hi,

I'm running Apache 2.4.41 on CentOS 6.4 server.

There was a problem (memory corruption),
when graceful reloading the httpd service many times.

The version of each app is as follows:
 - httpd-2.4.41
 - apr-1.5.2
 - apr-util-1.5.4
 - php-7.3.4

The following steps will cause the problem.

 # cat /opt/httpd/htdocs/index.php
 ------
 <?php
 phpinfo();
 ?>
 ------

 # /etc/init.d/httpd start
 Starting httpd:                                            [  OK  ]


Display phpinfo() in your browser and check that it is working.
 http://localhost/index.php


Now, when I run the following script, an error occurs (about 1023
times).

 # for i in $(seq 1030) ; do echo $i; /opt/httpd/bin/httpd -k graceful; 
done

 # less /opt/httpd/log/error_log
 ・・・・
 [XXX XXX XX 16:05:23.261688 2020] [mpm_prefork:notice] [pid 2875]
AH00171: Graceful restart requested, doing restart
 *** glibc detected *** /opt/httpd/bin/httpd: malloc(): memory
corruption: 0x00000000021a4010 ***
 *** glibc detected *** /opt/httpd/bin/httpd: malloc(): memory
corruption: 0x00000000021a4010 ***



This bug occurs when loading the libphp7.so module.
Different libphp7.so versions have the same result.
But that doesn't happen with the libphp5.so module.
It occurs on CentOS 7 as well as CentOS 6.

Thanks,
Regards.


-- 
Edit bug report at https://bugs.php.net/bug.php?id=79550&edit=1
-- 
Fix committed:                    https://bugs.php.net/fix.php?id=79550&r=fixed
Fixed in release:                 https://bugs.php.net/fix.php?id=79550&r=alreadyfixed
Need backtrace:                   https://bugs.php.net/fix.php?id=79550&r=needtrace
Need Reproduce Script:            https://bugs.php.net/fix.php?id=79550&r=needscript
Try newer version:                https://bugs.php.net/fix.php?id=79550&r=oldversion
Not developer issue:              https://bugs.php.net/fix.php?id=79550&r=support
Expected behavior:                https://bugs.php.net/fix.php?id=79550&r=notwrong
Not enough info:                  https://bugs.php.net/fix.php?id=79550&r=notenoughinfo
Submitted twice:                  https://bugs.php.net/fix.php?id=79550&r=submittedtwice
register_globals:                 https://bugs.php.net/fix.php?id=79550&r=globals
PHP version support discontinued: https://bugs.php.net/fix.php?id=79550&r=phptooold
Daylight Savings:                 https://bugs.php.net/fix.php?id=79550&r=dst
IIS Stability:                    https://bugs.php.net/fix.php?id=79550&r=isapi
Install GNU Sed:                  https://bugs.php.net/fix.php?id=79550&r=gnused
Floating point limitations:       https://bugs.php.net/fix.php?id=79550&r=float
No Zend Extensions:               https://bugs.php.net/fix.php?id=79550&r=nozend
MySQL Configuration Error:        https://bugs.php.net/fix.php?id=79550&r=mysqlcfg


Thread (6 messages)

« previous php.bugs (#226866) next »