Bug #79550 [Com]: Reloading the httpd service repeatedly causes a memory corruption error.

From: Date: Thu, 07 May 2020 02:10:48 +0000
Subject: Bug #79550 [Com]: Reloading the httpd service repeatedly causes a memory corruption error.
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-226942@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=79550&edit=1 ID: 79550 Comment by: kitagawa at sraoss dot co dot jp Reported by: kitagawa at sraoss dot co dot jp Summary: Reloading the httpd service repeatedly causes a memory corruption error. Status: Open Type: Bug Package: Apache2 related Operating System: Linux PHP Version: 7.3.17 Block user comment: N Private report: N New Comment: Thank you for your comment. Did a similar problem occur with "imap.so"? Currently, we continue to provide services including restart, but we want to restart and operate as safely as possible. Also, there are many servers that are graceful restart all over the world(including logrotate), so I would like to ask for a fundamental response. Previous Comments: ------------------------------------------------------------------------ [2020-05-01 08:25:05] bugreports at gmail dot com chck out which extensions are loaded, on Fedora for some time "imap.so" loaded had a similar result so that i switched to restart instead of reload on machins which need it ------------------------------------------------------------------------ [2020-05-01 07:33:58] kitagawa at sraoss dot co dot jp Description: ------------ Hi, I'm running Apache 2.4.41 on CentOS 6.4 server. There was a problem (memory corruption), when graceful reloading the httpd service many times. The version of each app is as follows: - httpd-2.4.41 - apr-1.5.2 - apr-util-1.5.4 - php-7.3.4 The following steps will cause the problem. # cat /opt/httpd/htdocs/index.php ------ <?php phpinfo(); ?> ------ # /etc/init.d/httpd start Starting httpd: [ OK ] Display phpinfo() in your browser and check that it is working. http://localhost/index.php Now, when I run the following script, an error occurs (about 1023 times). # for i in $(seq 1030) ; do echo $i; /opt/httpd/bin/httpd -k graceful; done # less /opt/httpd/log/error_log ・・・・ [XXX XXX XX 16:05:23.261688 2020] [mpm_prefork:notice] [pid 2875] AH00171: Graceful restart requested, doing restart *** glibc detected *** /opt/httpd/bin/httpd: malloc(): memory corruption: 0x00000000021a4010 *** *** glibc detected *** /opt/httpd/bin/httpd: malloc(): memory corruption: 0x00000000021a4010 *** This bug occurs when loading the libphp7.so module. Different libphp7.so versions have the same result. But that doesn't happen with the libphp5.so module. It occurs on CentOS 7 as well as CentOS 6. Thanks, Regards. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=79550&edit=1

« previous php.bugs (#226942) next »