Bug #71984 [Com]: SOAP-ERROR: Parsing WSDL: Couldn't load from...
| From: | anthony dot ferrara at sgkinc dot com | Date: | Wed, 24 Mar 2021 21:07:59 +0000 |
| Subject: | Bug #71984 [Com]: SOAP-ERROR: Parsing WSDL: Couldn't load from... | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-232983@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=71984&edit=1
ID: 71984
Comment by: anthony dot ferrara at sgkinc dot com
Reported by: stef at rouschop dot com
Summary: SOAP-ERROR: Parsing WSDL: Couldn't load from...
Status: Feedback
Type: Bug
Package: SOAP related
Operating System: Ubuntu 14.4
PHP Version: 7.0.5
Assigned To: cmb
Block user comment: N
Private report: N
New Comment:
I am seeing this problem. PHP version 7.3.14. ext/openssl is enabled.
Previous Comments:
------------------------------------------------------------------------
[2021-03-23 16:35:58] cmb@php.net
I cannot reproduce this with PHP-7.4. Can anybody else reproduce
with any of the actively supported PHP versions[1] (and OpenSSL
enabled)?
[1] <https://www.php.net/supported-versions.php>
------------------------------------------------------------------------
[2018-10-10 11:18:11] jan dot zelenka at clickworks dot eu
Sorry all, after some more digging it turned out to be my mistake: the extension php_openssl was not
enabled.
------------------------------------------------------------------------
[2018-10-10 08:03:16] jan dot zelenka at clickworks dot eu
I experience the same issue on PHP 5.6 on Windows.
What I want to add is that the WSDL provider offers both http and https protocols for linking with
the WSDL definition. We've been using http happily all the time. It's https where things
go wrong. Hope this helps.
------------------------------------------------------------------------
[2018-01-11 11:44:33] jitesh dot gondaliya at techcronus dot com
Hi i am getting SOAP-ERROR: Parsing WSDL: Couldn't load from
Please help me for that
------------------------------------------------------------------------
[2016-04-13 07:45:59] stef at rouschop dot com
Yes, openssl is enabled.
I asked the owner of the webservice to look into his server log. He cannot find an entry of my
server trying to connect. When I do a cURL request to this server it will work correctly and is also
recorded in the serverlog.
On our other server with 7.0.3-5+deb.sury.org~trusty+1. The SOAP runs like it should.
Are you able to reproduce this?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=71984
--
Edit this bug report at https://bugs.php.net/bug.php?id=71984&edit=1