Bug #78485 [Opn->Fbk]: Random "couldn't resolve host" failures in curl_multi
| From: | cmb@php.net | Date: | Wed, 22 Sep 2021 12:34:30 +0000 |
| Subject: | Bug #78485 [Opn->Fbk]: Random "couldn't resolve host" failures in curl_multi | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-236748@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=78485&edit=1
ID: 78485
Updated by: cmb@php.net
Reported by: sinus at sinpi dot net
Summary: Random "couldn't resolve host" failures in
curl_multi
-Status: Open
+Status: Feedback
Type: Bug
Package: opcache
Operating System: CloudLinux
-PHP Version: 7.2.22
+PHP Version: 7.3.9
-Assigned To:
+Assigned To: cmb
Block user comment: N
Private report: N
New Comment:
Is this still an issue with any of the actively supported PHP
versions[1]?
[1] <https://www.php.net/supported-versions.php>
Previous Comments:
------------------------------------------------------------------------
[2019-09-06 14:27:52] sinus at sinpi dot net
Oddly enough, enabling or disabling of any PHP modules was causing the errors to either visibly
decrease, or just as significantly increase in frequency.
Updating to PHP 7.3.9, still cURL 7.62.0, stabilized the issue enough to say: enabling opcache
causes failures to create getaddrinfo threads.
------------------------------------------------------------------------
[2019-09-03 15:43:27] sinus at sinpi dot net
The situation develops. Disabling the opcache module made the issue go away entirely!
------------------------------------------------------------------------
[2019-09-03 09:26:09] sinus at sinpi dot net
I now added CURLOPT_VERBOSE output to the bug.php script, and it demonstrated the failing handle
throwing the following at me:
* getaddrinfo() thread failed to start
The plot thickens.
------------------------------------------------------------------------
[2019-09-02 21:17:57] sinus at sinpi dot net
Seeing as I've never seen this happen on my previous host, I suspect it's a conflict with
some local setup, not a bug in curl itself - but it'd be nice if there was a way to find out
what could possibly cause it to behave like that.
------------------------------------------------------------------------
[2019-09-02 20:54:23] sinus at sinpi dot net
You might have to reload it a few times, as I said, it's pretty random. Reproductions of the
bug are seen as "Msg: 6 for handle <x>".
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=78485
--
Edit this bug report at https://bugs.php.net/bug.php?id=78485&edit=1