Bug #78485 [Fbk->NoF]: Random "couldn't resolve host" failures in curl_multi
| From: | php-bugs at lists dot php dot net | Date: | Sun, 03 Oct 2021 04:22:13 +0000 |
| Subject: | Bug #78485 [Fbk->NoF]: Random "couldn't resolve host" failures in curl_multi | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-236983@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=78485&edit=1
ID: 78485
Updated by: php-bugs@lists.php.net
Reported by: sinus at sinpi dot net
Summary: Random "couldn't resolve host" failures in curl_multi
-Status: Feedback
+Status: No Feedback
Type: Bug
Package: opcache
Operating System: CloudLinux
PHP Version: 7.3.9
Assigned To: cmb
Private report: N
New Comment:
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
Previous Comments:
------------------------------------------------------------------------
[2021-09-22 12:34:30] cmb@php.net
Is this still an issue with any of the actively supported PHP
versions[1]?
[1] <https://www.php.net/supported-versions.php>
------------------------------------------------------------------------
[2019-09-06 14:27:52] sinus at sinpi dot net
Oddly enough, enabling or disabling of any PHP modules was causing the errors to either visibly
decrease, or just as significantly increase in frequency.
Updating to PHP 7.3.9, still cURL 7.62.0, stabilized the issue enough to say: enabling opcache
causes failures to create getaddrinfo threads.
------------------------------------------------------------------------
[2019-09-03 15:43:27] sinus at sinpi dot net
The situation develops. Disabling the opcache module made the issue go away entirely!
------------------------------------------------------------------------
[2019-09-03 09:26:09] sinus at sinpi dot net
I now added CURLOPT_VERBOSE output to the bug.php script, and it demonstrated the failing handle
throwing the following at me:
* getaddrinfo() thread failed to start
The plot thickens.
------------------------------------------------------------------------
[2019-09-02 21:17:57] sinus at sinpi dot net
Seeing as I've never seen this happen on my previous host, I suspect it's a conflict with
some local setup, not a bug in curl itself - but it'd be nice if there was a way to find out
what could possibly cause it to behave like that.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=78485
--
Edit this bug report at https://bugs.php.net/bug.php?id=78485&edit=1