#19758 [Csd->Bgs]: Loading extensions isn't functional
| From: | sniper@php.net | Date: | Sat, 02 Nov 2002 03:46:23 +0000 |
| Subject: | #19758 [Csd->Bgs]: Loading extensions isn't functional | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-23928@lists.php.net to get a copy of this message | ||
ID: 19758
Updated by: sniper@php.net
Reported By: cbrady@sbccd.cc.ca.us
-Status: Closed
+Status: Bogus
Bug Type: Dynamic loading
Operating System: Win 2000 Server
PHP Version: 4.2.3
New Comment:
still bogus, try reading the docs more often..
Previous Comments:
------------------------------------------------------------------------
[2002-11-01 14:46:47] cbrady@sbccd.cc.ca.us
For those who read this, here was the resolution to the problem:
php_mssql.dll uses other dlls to function. These DLL's are located in
the DLL directory under the php directory. These need to be placed it
the System32 directory on your machine.
In my particular case, the ntwdblib.dll wasn't in the directory. Once
placed it worked fine.
However, I would still call this a bug. The Error message incorrectly
notifies us of this problem. It says can't find php_mssql.php dll, but
acctually it should of said "ntwdblib.dll DLL not found"
------------------------------------------------------------------------
[2002-10-07 13:09:18] cbrady@sbccd.cc.ca.us
My appologizes for posting this report, if this truly isn't a bug.
However, Win 2000 Server comes with the mssql drivers, so all that is
needed is to load the php_mssql.dll. But, your extenesion_dir isn't
functioning so I can't do that.
I find it hard to believe, that with the correct configuration for the
extenesion_dir, and that it wouldn't ready any dll's in the specified
directory, you don't call this a bug.
I said before that I've installed php on 5 other windows 2000
computers, so I know my php.ini is correct.
Thanks for the help. I just hope support doesn't send me back here.
------------------------------------------------------------------------
[2002-10-05 02:53:25] sander@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php
Thank you for your interest in PHP.
You need to install the MSSSQL client DLLs.
------------------------------------------------------------------------
[2002-10-04 15:17:10] cbrady@sbccd.cc.ca.us
Well, since I thought I might have something miss installed, I've gone
ahead and re-started my Win2000 Server installation.
I'm back to the same problem however.
Error Message:
"Unable to load dynamic library 'd:\php\extensions\php_mssql.dll' - The
specified module could not be found"
Any directory I specify for the
extension_dir dll's, won't work. I've tried, d:\php\extensions,
d:\php\\extensions\, d:\\php\\extensions, d:\\php\exetensions\\,
d:/php/extensions, d://php//extensions,
d://php/extensions/, d://php//extensions//
I've attempted as well to move the dll into the system 32 directory,
and
in the same directory has the php.exe file. No luck.
Below are my specifications:
Server: Dell Power App 120 Server, SCSI hard drives.
OS: Window 2000 Server running IIS 5
PHP: Version 4.2.3 running ISAP installation
Php ini file : c:\WINNT\php.ini
Php directory : d:\php
Extension directory : d:\php\extensions
Note: I've installed this same version on 6 other Win2000 clients (Pro
and Server) with IIS 5, and have not run into this problem before. The
only main difference is that its a Power App Server, with SCSI drives.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19758&edit=1