#19753 [Com]: problem starting Apache: libphp4.so: undefined symbol: ap_block_alarms

From: Date: Mon, 11 Nov 2002 05:06:44 +0000
Subject: #19753 [Com]: problem starting Apache: libphp4.so: undefined symbol: ap_block_alarms
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-24513@lists.php.net to get a copy of this message
ID: 19753 Comment by: Dariush@sqlporter.com Reported By: pixie@nervesane.net Status: Bogus Bug Type: Apache2 related Operating System: Linux RedHat 7.1 PHP Version: 4.2.3 New Comment: I'm having the same problem. Have apache2 installed, Installed mod_php4 on freebsd using the ports collections. and exact same error as the user above Previous Comments: ------------------------------------------------------------------------ [2002-10-04 11:53:29] pixie@nervesane.net This is the latest confing I tried: --prefix=/usr/local --with--apx2=/usr/local/Apache/bin/apxs --enable-module=so --with-mod_charset --enable-sockets --enable-memory-limit --with-sybase=/usr/local/freetds And I still get this: Syntax error on line 259 of /usr/local/Apache/conf/httpd.conf: Cannot load /usr/local/Apache/modules/libphp4.so into server: /usr/local/Apache/modules/libphp4.so: undefined symbol: ap_block_alarms ------------------------------------------------------------------------ [2002-10-04 06:43:36] sander@php.net Why didn't you configure PHP with --with-apxs2=/path/to/apxs ? You seem to compile PHP as CGI, and then you can't use the LoadModule line. Please compile PHP with --with-apxs2 and reopen if the problem still persists. ------------------------------------------------------------------------ [2002-10-04 06:40:09] pixie@nervesane.net I tried the latest version available php4-200210040300 and I still get the same error. ------------------------------------------------------------------------ [2002-10-04 06:10:09] mfischer@php.net For the latest Apache you also need the latest PHP from snaps.php.net ------------------------------------------------------------------------ [2002-10-04 06:02:53] pixie@nervesane.net I'm in the process of upgrading to Apache 2.0.43 and PHP 4.2.3 1. Apache installation [without supporting PHP] was succesfful. 2. PHP 4.2.3 was also successful, this is my configure: --prefix=/usr/local --enable-module=so --with-mod_charset --enable-force-cgi-direct --enable-discard-path --with-xml=shared --enable-sockets --enable-memory-limit --with-sybase=/usr/local/freetds I tried other configure options too. Everything seems to work fine separate (ex. a simple php shell script works). THe problem comes when I try to start apache: /usr/local/Apache/bin/apachectl start I get this: Syntax error on line 231 of /usr/local/Apache/conf/httpd.conf: Cannot load /usr/local/Apache/lib/libphp4.so into server: /usr/local/Apache/lib/libphp4.so: undefined symbol: ap_block_alarms Line 231 is: LoadModule php4_module lib/libphp4.so I did a Google search and other people are having the same problem. No solutions were provided anywhere. Thanks. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19753&edit=1

« previous php.bugs (#24513) next »