#19753 [Com]: problem starting Apache: libphp4.so: undefined symbol: ap_block_alarms

From: Date: Wed, 14 Apr 2004 17:31:22 +0000
Subject: #19753 [Com]: problem starting Apache: libphp4.so: undefined symbol: ap_block_alarms
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-58135@lists.php.net to get a copy of this message
ID: 19753 Comment by: fox at o2 dot pl Reported By: pixie at nervesane dot net Status: Bogus Bug Type: Apache2 related Operating System: Linux RedHat 7.1 PHP Version: 4.2.3 New Comment: got the same problem, but now its fix. The solution is easy, you probably configuring sources wrong. ./configure --with-apxs2=/path/to/apache2/bin/apxs --with-mysql try this Previous Comments: ------------------------------------------------------------------------ [2002-11-10 23:06:43] Dariush at sqlporter dot com I'm having the same problem. Have apache2 installed, Installed mod_php4 on freebsd using the ports collections. and exact same error as the user above ------------------------------------------------------------------------ [2002-10-04 11:53:29] pixie at nervesane dot net This is the latest confing I tried: --prefix=/usr/local --with--apx2=/usr/local/Apache/bin/apxs --enable-module=so --with-mod_charset --enable-sockets --enable-memory-limit --with-sybase=/usr/local/freetds And I still get this: Syntax error on line 259 of /usr/local/Apache/conf/httpd.conf: Cannot load /usr/local/Apache/modules/libphp4.so into server: /usr/local/Apache/modules/libphp4.so: undefined symbol: ap_block_alarms ------------------------------------------------------------------------ [2002-10-04 06:43:36] sander@php.net Why didn't you configure PHP with --with-apxs2=/path/to/apxs ? You seem to compile PHP as CGI, and then you can't use the LoadModule line. Please compile PHP with --with-apxs2 and reopen if the problem still persists. ------------------------------------------------------------------------ [2002-10-04 06:40:09] pixie at nervesane dot net I tried the latest version available php4-200210040300 and I still get the same error. ------------------------------------------------------------------------ [2002-10-04 06:10:09] mfischer@php.net For the latest Apache you also need the latest PHP from snaps.php.net ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19753 -- Edit this bug report at http://bugs.php.net/?id=19753&edit=1

« previous php.bugs (#58135) next »