#19739 [Fbk->NoF]: php-4.2.3 fails to Install with Apache 2.0.42 on AIX 5.1 ML2

From: Date: Wed, 01 Jan 2003 07:00:05 +0000
Subject: #19739 [Fbk->NoF]: php-4.2.3 fails to Install with Apache 2.0.42 on AIX 5.1 ML2
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-28864@lists.php.net to get a copy of this message
ID: 19739 Updated by: php-bugs@lists.php.net Reported By: php@thater.net -Status: Feedback +Status: No Feedback Bug Type: Apache2 related Operating System: AIX 5.1 PHP Version: 4.3.0-dev New Comment: No feedback was provided for this bug for over 2 weeks, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". Previous Comments: ------------------------------------------------------------------------ [2002-12-10 13:48:00] php@thater.net Tried it out with latest version ('php4-200212101630') with ML03 of AIX 5.1 1) as the very last message, configure prints twice the message './config.status[1823]: 6: bad file unit number' 2) compile fails with '/home/www/staging/httpd/bin/httpd.exp: No such file or directory' Guido ------------------------------------------------------------------------ [2002-12-08 17:07:41] iliaa@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-10-22 01:10:59] php@thater.net Here are my experiences with php4-200210202100: ./configure determins a wrong location of httpd.exp in line 4582: As in linee 3169, the location for httpd.exp should be read from LIBEXECDIR (instead of SBINDIR). Having manually fixed that, 'make' worked fine, libphp4.a is placed in .libs 'make install' then fails with: [www@ibm php4-200210202100]$ make install Installing PHP SAPI module /home/www/staging/www/build/instdso.sh SH_LIBTOOL='/home/www/staging/www/build/libtool' libphp4.la /home/www/staging/httpd/modules rm -f /home/www/staging/httpd/modules/libphp4.so /home/www/staging/www/build/libtool --mode=install cp libphp4.la /home/www/staging/httpd/modules/ cp .libs/libphp4.lai /home/www/staging/httpd/modules/libphp4.la cp .libs/libphp4.a /home/www/staging/httpd/modules/libphp4.a ranlib /home/www/staging/httpd/modules/libphp4.a chmod 644 /home/www/staging/httpd/modules/libphp4.a libtool: install: warning: remember to run `libtool --finish /home/www/wrk/php4-200210202100/libs' Warning! dlname not found in /home/www/staging/httpd/modules/libphp4.la. Assuming installing a .so rather than a libtool archive. chmod 755 /home/www/staging/httpd/modules/libphp4.so chmod: /home/www/staging/httpd/modules/libphp4.so: A file or directory in the path name does not exist. apxs:Error: Command failed with rc=65536 . make: *** [install-sapi] Error 1 [www@ibm php4-200210202100]$ Haven't had the time yet to figure out what's going wrong (obviously .so can't be created), will investigate this (hopefully) later this day. Guido ------------------------------------------------------------------------ [2002-10-05 08:42:12] php@thater.net Latest version (php4-200210050000) fails to configure, debug.log is CONFIGURE: './configure' '--prefix=/home/www/staging/php' '--with-mysql=/usr/local/mysql/' '--with-apxs2=/home/www/staging/httpd/bin/apxs' '--cache-file=guido.log' CC: gcc CFLAGS: -g -O2 CPPFLAGS: CXX: CXXFLAGS: INCLUDES: -I/home/www/staging/httpd/include -I$(top_builddir)/Zend -I/usr/local/mysql//include/mysql LDFLAGS: -Wl,-rpath,/usr/local/mysql//lib/mysql -L/usr/local/mysql//lib/mysql LIBS: -lmysqlclient -lz -lcrypt -lm -ldl -lcrypt DLIBS: SAPI: apache2filter PHP_RPATHS: /usr/local/mysql//lib/mysql uname -a: AIX ibm 1 5 00050180C000 gcc -o conftest -g -O2 -Wl,-rpath,/usr/local/mysql//lib/mysql -L/usr/local/mysql//lib/mysql conftest.c -lmysqlclient -lz -lcrypt -lm -ldl -lcrypt 1>&5 Could not load program ./conftest: Dependent module libc.a(shr.o) could not be loaded. Could not load module libc.a(shr.o). Error was: No such file or directory ------------------------------------------------------------------------ [2002-10-03 14:04:47] sander@php.net You'd better not mess with the Makefile - you probably forgot something and that ruins the build process. Why did you need to? What did go wrong during configure? Look in config.cache for more information. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19739 -- Edit this bug report at http://bugs.php.net/?id=19739&edit=1

« previous php.bugs (#28864) next »