#19739 [Com]: php-4.2.3 fails to Install with Apache 2.0.42 on AIX 5.1 ML2

From: Date: Wed, 19 Mar 2003 09:13:04 +0000
Subject: #19739 [Com]: php-4.2.3 fails to Install with Apache 2.0.42 on AIX 5.1 ML2
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-35914@lists.php.net to get a copy of this message
ID: 19739 Comment by: pascal at vmfacility dot fr Reported By: php at thater dot net Status: No Feedback Bug Type: Apache2 related Operating System: AIX 5.1 PHP Version: 4.3.0-dev New Comment: with apache 2.0.44 and php 4.3.2rc2 on the same platform AIX 5.1 ml3 I have a problem with the installation of libphp4.so in the target directory. seems to be a bug in libtool or instdso.sh. my configure is : ./configure \ --with-apxs2=/usr/local/apache2/bin/apxs \ --with-apxs2-filter=/usr/local/apache2/bin/apxs \ --with-apxs2handler=/usr/local/apache2/bin/apxs \ --with-apache2=/usr/local/apache2 \ --with-mysql=/usr/local/mysql \ --with-openssl=/usr/local/ssl \ --with-zlib-dir=/usr/local/src/zlib-1.1.4 \ --with-gd \ --enable-discard-path \ --disable-force-cgi-redirect \ --enable-shared \ --disable-static \ --disable-debug \ --disable-rpath \ --enable-pic \ --enable-inline-optimization \ --enable-memory-limit \ --enable-magic-quotes \ --enable-debugger \ --enable-track-vars \ --with-versioning \ --with-mod_charset \ --with-regex=php \ --with-pear \ --enable-track-vars \ --enable-trans-sid \ --enable-safe-mode \ --enable-ctype \ --enable-ftp \ --enable-posix \ --enable-session \ --enable-sysvsem \ --enable-sysvshm \ --enable-yp \ --without-kerberos make is OK make install does not succeed because libphp4.so is not copied to TARGETDIR : Installing PHP SAPI module /usr/local/apache2/build/instdso.sh SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp4.la /usr/local/apache2/modules + test 3 != 3 + + echo SH_LIBTOOL=/usr/local/apache2/build/libtool + sed -e s/^SH_LIBTOOL=// SH_LIBTOOL=/usr/local/apache2/build/libtool + DSOARCHIVE=libphp4.la + + basename libphp4.la DSOARCHIVE_BASENAME=libphp4.la + TARGETDIR=/usr/local/apache2/modules + + sed -e s/\.la$// + echo libphp4.la DSOBASE=libphp4 + TARGET_NAME=libphp4.so + ls -l /usr/local/apache2/modules total 16 -rw-r--r-- 1 bin bin 8035 Mar 17 19:13 httpd.exp + + uname -s SYS=AIX + test AIX = AIX + CMD=rm -f /usr/local/apache2/modules/libphp4.so + echo rm -f /usr/local/apache2/modules/libphp4.so rm -f /usr/local/apache2/modules/libphp4.so + rm -f /usr/local/apache2/modules/libphp4.so + CMD=/usr/local/apache2/build/libtool --mode=install cp libphp4.la /usr/local/apache2/modules/ + echo /usr/local/apache2/build/libtool --mode=install cp libphp4.la /usr/local/apache2/modules/ /usr/local/apache2/build/libtool --mode=install cp libphp4.la /usr/local/apache2/modules/ + /usr/local/apache2/build/libtool --mode=install cp libphp4.la /usr/local/apache2/modules/ cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la libtool: install: warning: remember to run `libtool --finish /usr/local/src/php-4.3.2RC1/libs' + test AIX = OS/2 + + grep ^dlname /usr/local/apache2/modules/libphp4.la + sed -e s/dlname='\([^']*\)'/\1/ DLNAME=libphp4.so + + grep library_names /usr/local/apache2/modules/libphp4.la + sed -e s/dlname='\([^']*\)'/\1/ LIBRARY_NAMES=library_names='libphp4.a libphp4.a' + + echo library_names='libphp4.a libphp4.a' + sed -e s/ *libphp4.so//g LIBRARY_NAMES=library_names='libphp4.a libphp4.a' + test -z libphp4.so + ls -l /usr/local/apache2/modules total 19440 -rw-r--r-- 1 bin bin 8035 Mar 17 19:13 httpd.exp -rw-r--r-- 1 root system 9939429 Mar 18 15:19 libphp4.a -rw-r--r-- 1 root system 814 Mar 18 15:19 libphp4.la + test -n library_names='libphp4.a libphp4.a' + rm -f /usr/local/apache2/modules/library_names='libphp4.a + rm -f /usr/local/apache2/modules/libphp4.a' + ls -l /usr/local/apache2/modules total 19440 -rw-r--r-- 1 bin bin 8035 Mar 17 19:13 httpd.exp -rw-r--r-- 1 root system 9939429 Mar 18 15:19 libphp4.a -rw-r--r-- 1 root system 814 Mar 18 15:19 libphp4.la + test libphp4.so != libphp4.so + ls -l /usr/local/apache2/modules total 19440 -rw-r--r-- 1 bin bin 8035 Mar 17 19:13 httpd.exp -rw-r--r-- 1 root system 9939429 Mar 18 15:19 libphp4.a -rw-r--r-- 1 root system 814 Mar 18 15:19 libphp4.la + rm -f /usr/local/apache2/modules/libphp4.la + rm -f /usr/local/apache2/modules/libphp4.a + rm -f /usr/local/apache2/modules/liblibphp4.a + rm -f /usr/local/apache2/modules/liblibphp4.so + exit 0 chmod 755 /usr/local/apache2/modules/libphp4.so chmod: /usr/local/apache2/modules/libphp4.so: No such file or directory apxs:Error: Command failed with rc=65536 . make: The error code from the last command is 1. Stop. content of .libs seems OK : # ls -l .libs total 38496 -rw-r--r-- 1 root system 9939429 Mar 18 15:16 libphp4.a -rw-r--r-- 1 root system 45312 Mar 18 15:16 libphp4.exp lrwxrwxrwx 1 root system 13 Mar 18 15:16 libphp4.la -> ../libphp4.la -rw-r--r-- 1 root system 814 Mar 18 15:16 libphp4.lai -rwxr-xr-x 1 root system 9715134 Mar 18 15:16 libphp4.so I've added 'ls -l $TARGETDIR' at some points in /usr/local/apache2/build/instdso.sh I've noted a typo on this script: a sed to remove 'dlnames' is erroneoulsly done to build LIBRARY_NAMES instead of a sed to remove 'library_names' but correcting this does not correct this bug. Previous Comments: ------------------------------------------------------------------------ [2003-01-08 03:24:07] firmani at istat dot it I have the same problem submitted above with AIX 4.3.3 and php4.3.0 apache2.0.43. I used gcc version 2.95.3 20010315. I ignored the './config.status[1823]: 6: bad file unit number' error and did a make which ended with the an error because the apxs script was not found. I modified the Makefile with the correct location of the apxs script as submitted here by Guido and did a make which was fine this time. But then the install process failed because the libphp4.so was not copied to the LIBEXECDIR of apache as pointed out again by Guido. Maurizio ------------------------------------------------------------------------ [2003-01-01 01:00:03] php-bugs at lists dot php dot net No feedback was provided for this bug for over 2 weeks, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". ------------------------------------------------------------------------ [2002-12-10 13:48:00] php at thater dot net Tried it out with latest version ('php4-200212101630') with ML03 of AIX 5.1 1) as the very last message, configure prints twice the message './config.status[1823]: 6: bad file unit number' 2) compile fails with '/home/www/staging/httpd/bin/httpd.exp: No such file or directory' Guido ------------------------------------------------------------------------ [2002-12-08 17:07:41] iliaa@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-10-22 01:10:59] php at thater dot net Here are my experiences with php4-200210202100: ./configure determins a wrong location of httpd.exp in line 4582: As in linee 3169, the location for httpd.exp should be read from LIBEXECDIR (instead of SBINDIR). Having manually fixed that, 'make' worked fine, libphp4.a is placed in .libs 'make install' then fails with: [www@ibm php4-200210202100]$ make install Installing PHP SAPI module /home/www/staging/www/build/instdso.sh SH_LIBTOOL='/home/www/staging/www/build/libtool' libphp4.la /home/www/staging/httpd/modules rm -f /home/www/staging/httpd/modules/libphp4.so /home/www/staging/www/build/libtool --mode=install cp libphp4.la /home/www/staging/httpd/modules/ cp .libs/libphp4.lai /home/www/staging/httpd/modules/libphp4.la cp .libs/libphp4.a /home/www/staging/httpd/modules/libphp4.a ranlib /home/www/staging/httpd/modules/libphp4.a chmod 644 /home/www/staging/httpd/modules/libphp4.a libtool: install: warning: remember to run `libtool --finish /home/www/wrk/php4-200210202100/libs' Warning! dlname not found in /home/www/staging/httpd/modules/libphp4.la. Assuming installing a .so rather than a libtool archive. chmod 755 /home/www/staging/httpd/modules/libphp4.so chmod: /home/www/staging/httpd/modules/libphp4.so: A file or directory in the path name does not exist. apxs:Error: Command failed with rc=65536 . make: *** [install-sapi] Error 1 [www@ibm php4-200210202100]$ Haven't had the time yet to figure out what's going wrong (obviously .so can't be created), will investigate this (hopefully) later this day. Guido ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19739 -- Edit this bug report at http://bugs.php.net/?id=19739&edit=1

« previous php.bugs (#35914) next »