#21429 [NEW]: apache2 fails to load php-4.3.0
| From: | dev at news4sites dot com | Date: | Sun, 05 Jan 2003 13:16:23 +0000 |
| Subject: | #21429 [NEW]: apache2 fails to load php-4.3.0 | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-29101@lists.php.net to get a copy of this message | ||
From: dev@news4sites.com
Operating system: linux8
PHP version: 4.3.0
PHP Bug Type: Apache2 related
Bug description: apache2 fails to load php-4.3.0
I installed apache-2.0.43 and php-4.3.0 following steps listed at
http://www.php.net/manual/en/install.apache2.php
apache installs fine with
./configure --enable-so
make
make install
php installs fine with
./configure --with-apxs2=/usr/local/apache2/bin/apxs
make
make install
Problem starts with when we add
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php
apache fails to start saying module
/downloads/php-4.3.0/sapi/apache2filter/sapi_apache2.c is not compatible
with this version of apache (found 20020628, need 20020903). Please
contact the vendor for the correct version.
apache starts fine when load module statement is commented.
Thank you for your help
abhay aggarwal
--
Edit bug report at http://bugs.php.net/?id=21429&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=21429&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=21429&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=21429&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=21429&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=21429&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=21429&r=support
Expected behavior: http://bugs.php.net/fix.php?id=21429&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=21429&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=21429&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=21429&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=21429&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=21429&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=21429&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=21429&r=gnused