#21910 [NEW]: Can't authenticate if a '+' is in the password
| From: | sitz at onastick dot net | Date: | Mon, 27 Jan 2003 19:11:41 +0000 |
| Subject: | #21910 [NEW]: Can't authenticate if a '+' is in the password | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-31360@lists.php.net to get a copy of this message | ||
From: sitz@onastick.net
Operating system: Linux 2.4
PHP version: 4.2.2
PHP Bug Type: PostgreSQL related
Bug description: Can't authenticate if a '+' is in the password
Attempts to authenticate against a postgres DB (v 7.2) if there's a '+' in
the password fails. If the password is "f00+f3ti5h", the error is:
[27-Jan-2003 10:33:42] PHP Warning: pg_connect() unable to connect to
PostgreSQL server: missing "=" after "f3ti5h" in connection info string
This error does not occur when accessing the same DB with the same
user/pass in a perl CGI running on the same server, and it goes away if
the '+' is removed from the password.
--
Edit bug report at http://bugs.php.net/?id=21910&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=21910&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=21910&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=21910&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=21910&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=21910&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=21910&r=support
Expected behavior: http://bugs.php.net/fix.php?id=21910&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=21910&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=21910&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=21910&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=21910&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=21910&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=21910&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=21910&r=gnused