#21910 [Opn->Fbk]: Can't authenticate if a '+' is in the password
| From: | iliaa@php.net | Date: | Mon, 27 Jan 2003 20:56:10 +0000 |
| Subject: | #21910 [Opn->Fbk]: Can't authenticate if a '+' is in the password | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-31369@lists.php.net to get a copy of this message | ||
ID: 21910
Updated by: iliaa@php.net
Reported By: sitz@onastick.net
-Status: Open
+Status: Feedback
Bug Type: PostgreSQL related
Operating System: Linux 2.4
PHP Version: 4.2.2
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
If it still does not work, please indicate how you are specifying the
connection string (separate arguments or a single connection string).
Previous Comments:
------------------------------------------------------------------------
[2003-01-27 13:11:41] sitz@onastick.net
Attempts to authenticate against a postgres DB (v 7.2) if there's a '+'
in the password fails. If the password is "f00+f3ti5h", the error is:
[27-Jan-2003 10:33:42] PHP Warning: pg_connect() unable to connect to
PostgreSQL server: missing "=" after "f3ti5h" in connection info
string
This error does not occur when accessing the same DB with the same
user/pass in a perl CGI running on the same server, and it goes away if
the '+' is removed from the password.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21910&edit=1