#21908 [Com]: File upload problems beginning in 4.3.0
| From: | arkadi at it dot lv | Date: | Fri, 31 Jan 2003 15:21:27 +0000 |
| Subject: | #21908 [Com]: File upload problems beginning in 4.3.0 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-31765@lists.php.net to get a copy of this message | ||
ID: 21908
Comment by: arkadi@it.lv
Reported By: fn@panix.com
Status: Open
Bug Type: *General Issues
Operating System: NetBSD-1.5.2
PHP Version: 4.3.0
New Comment:
I also expirienced this problem. In my case I had "file_uploads = Off"
in php.ini and then "php_flag file_uploads on" for every virtual host
that require upload. That works perfectly in 4.2.3. According to
phpinfo() setting private flag have no effect for this option in 4.3.0.
I was forced to enable file uploads on system level in php.ini to solve
the problem.
Previous Comments:
------------------------------------------------------------------------
[2003-01-29 09:34:37] fn@panix.com
We are running both the apache module and the cgi. The problem is
present in both. However, it was not present in 4.2.3 (both the apache
module and the standalone version).
------------------------------------------------------------------------
[2003-01-29 00:02:07] sniper@php.net
And is PHP compiled as module in Apache or are you
running it as CGI?
------------------------------------------------------------------------
[2003-01-28 12:47:52] fn@panix.com
There is no error message from that script. It fails silently.
We are using Apache-1.3.27.
Thanks for your help.
------------------------------------------------------------------------
[2003-01-27 17:09:01] sniper@php.net
What apache version? What is the output of your script?
------------------------------------------------------------------------
[2003-01-27 12:38:44] fn@panix.com
I am running the following code in php-4.3.0:
<?
$portrait = $_FILES["portrait"];
print "<hr>_FILES[portrait]: <pre>\n";
print_r($portrait);
print "</pre>";
$portrait = $_GLOBALS["portrait"];
print "<hr>_FILES[portrait]: <pre>\n";
print_r($portrait);
print $_FILES["portrait"]["error"];
print "</pre>";
?>
<form method="post"
action="t.cgi"
ENCTYPE="multipart/form-data">
<INPUT TYPE="hidden" name="MAX_FILE_SIZE" value="1000000">
<input type=file name=portrait>
<input type="submit">
</form>
The file does not appear to be uploaded. However, with php-4.2.3,
everything works fine. I have confirmed that both file_uploads and
register_globals are on. This problem occurs in both the apache
module
and the standalone version.
is_uploaded_file() also reports failure with php-4.3.0.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21908&edit=1