#21908 [Opn->Fbk]: File upload problems beginning in 4.3.0
| From: | sniper@php.net | Date: | Mon, 03 Feb 2003 13:29:35 +0000 |
| Subject: | #21908 [Opn->Fbk]: File upload problems beginning in 4.3.0 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-31968@lists.php.net to get a copy of this message | ||
ID: 21908
Updated by: sniper@php.net
Reported By: fn@panix.com
-Status: Open
+Status: Feedback
Bug Type: *General Issues
Operating System: NetBSD-1.5.2
PHP Version: 4.3.0
New Comment:
Please try this script:
<form method="post" action="upload.php"
enctype="multipart/form-data">
<input type="file" name="portrait">
<input type="submit">
</form>
<?php
error_reporting(E_ALL);
var_dump($_FILES);
?>
If $_FILES array is empty after submit and no errors are given, try
this script:
<?php phpinfo(); ?>
And check the file upload related settings from the output:
post_max_size
file_uploads
upload_tmp_dir
upload_max_filesize
Also check your Apache error_log for any errors.
Previous Comments:
------------------------------------------------------------------------
[2003-01-31 09:21:27] arkadi@it.lv
I also expirienced this problem. In my case I had "file_uploads = Off"
in php.ini and then "php_flag file_uploads on" for every virtual host
that require upload. That works perfectly in 4.2.3. According to
phpinfo() setting private flag have no effect for this option in 4.3.0.
I was forced to enable file uploads on system level in php.ini to solve
the problem.
------------------------------------------------------------------------
[2003-01-29 09:34:37] fn@panix.com
We are running both the apache module and the cgi. The problem is
present in both. However, it was not present in 4.2.3 (both the apache
module and the standalone version).
------------------------------------------------------------------------
[2003-01-29 00:02:07] sniper@php.net
And is PHP compiled as module in Apache or are you
running it as CGI?
------------------------------------------------------------------------
[2003-01-28 12:47:52] fn@panix.com
There is no error message from that script. It fails silently.
We are using Apache-1.3.27.
Thanks for your help.
------------------------------------------------------------------------
[2003-01-27 17:09:01] sniper@php.net
What apache version? What is the output of your script?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/21908
--
Edit this bug report at http://bugs.php.net/?id=21908&edit=1