#22273 [NEW]: Cannot load libphp4.so into server: Unresolved external
| From: | germano60 at yahoo dot it | Date: | Tue, 18 Feb 2003 15:12:56 +0000 |
| Subject: | #22273 [NEW]: Cannot load libphp4.so into server: Unresolved external | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-33415@lists.php.net to get a copy of this message | ||
From: germano60 at yahoo dot it
Operating system: HP-UX 11.00
PHP version: 4.3.0
PHP Bug Type: Apache2 related
Bug description: Cannot load libphp4.so into server: Unresolved external
Hello
I already looked in the support resources and in the bug lists but could
not find a suitable clue.
I compiled apache and php then when I tried to start the web server, but
this is the error message I got:
Syntax error on line 233 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server: Unresolved
external
The error line did not return any further indications about which
"external" did not resolve.
Configuration:
hp-ux 11.00
php 4.3.0
apache 2.0.44
gcc 3.2
Apache was generated with:
./configure \
--prefix=/usr/local/apache2 \
--enable-so
Php4.3.0 was configured with:
./configure \
--with-mysql \
--with-apxs2=/usr/local/apache2/bin/apxs
I modified the configure script for PHP by replacing invokes of "-lcrypt"
with "-lc" and of "-ltermcap" with "-lcurses" to get libphp4.so
generated
by php's "make install" under the hp-ux 11 platform.
php's "make" and "make install" succeeded.
DSO modules were installed in the Apache2's default location
/usr/local/apache2/modules and this is also where PHP's make install
stored the library libphp4.so. In httpd.conf I added the following line:
LoadModule php4_module modules/libphp4.so
I'm not sure whether this is really a bug or due to my minimal
configuration - I tried some of the hints I found in the support/bugs but
without success.
Thanks in advance.
Germano Gasparini - germano60 at yahoo dot it
--
Edit bug report at http://bugs.php.net/?id=22273&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=22273&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=22273&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=22273&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=22273&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=22273&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=22273&r=support
Expected behavior: http://bugs.php.net/fix.php?id=22273&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=22273&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=22273&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=22273&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=22273&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=22273&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=22273&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=22273&r=gnused