#22273 [Opn->Fbk]: Cannot load libphp4.so into server: Unresolved external
| From: | sniper@php.net | Date: | Tue, 18 Feb 2003 17:53:23 +0000 |
| Subject: | #22273 [Opn->Fbk]: Cannot load libphp4.so into server: Unresolved external | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-33442@lists.php.net to get a copy of this message | ||
ID: 22273
Updated by: sniper@php.net
Reported By: germano60 at yahoo dot it
-Status: Open
+Status: Feedback
Bug Type: Apache2 related
Operating System: HP-UX 11.00
PHP Version: 4.3.0
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2003-02-18 09:12:56] germano60 at yahoo dot it
Hello
I already looked in the support resources and in the bug lists but
could not find a suitable clue.
I compiled apache and php then when I tried to start the web server,
but this is the error message I got:
Syntax error on line 233 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server:
Unresolved external
The error line did not return any further indications about which
"external" did not resolve.
Configuration:
hp-ux 11.00
php 4.3.0
apache 2.0.44
gcc 3.2
Apache was generated with:
./configure \
--prefix=/usr/local/apache2 \
--enable-so
Php4.3.0 was configured with:
./configure \
--with-mysql \
--with-apxs2=/usr/local/apache2/bin/apxs
I modified the configure script for PHP by replacing invokes of
"-lcrypt" with "-lc" and of "-ltermcap" with "-lcurses" to
get
libphp4.so generated by php's "make install" under the hp-ux 11
platform.
php's "make" and "make install" succeeded.
DSO modules were installed in the Apache2's default location
/usr/local/apache2/modules and this is also where PHP's make install
stored the library libphp4.so. In httpd.conf I added the following
line:
LoadModule php4_module modules/libphp4.so
I'm not sure whether this is really a bug or due to my minimal
configuration - I tried some of the hints I found in the support/bugs
but without success.
Thanks in advance.
Germano Gasparini - germano60 at yahoo dot it
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=22273&edit=1