#16325 [Com]: Memory leak causes DLLHOST to become large
| From: | nicolai at petri dot cc | Date: | Mon, 21 Apr 2003 12:25:24 +0000 |
| Subject: | #16325 [Com]: Memory leak causes DLLHOST to become large | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-37940@lists.php.net to get a copy of this message | ||
ID: 16325
Comment by: nicolai at petri dot cc
Reported By: mail-php dot net at kimihia dot org dot nz
Status: No Feedback
Bug Type: IIS related
Operating System: Windows 2000 Server
PHP Version: 4.1.2
New Comment:
This happens also for me with both php 4.3.1 and 4.3.2 RC1.
It also happens even if I don´t load any extensions, so the leak seems
to be in the core php stuff. I tested with my own pages and phpinfo()
pages. Each hit generates 2-3 Mb. of mem. leak.
Another (maybe related) observation i did, was that when I run with
mssql extension and use pconnect calls.. phpinfo() always shows 0
connections and 0 persistent connections. So maybe php cannot locate
it's runtime datastructures and re-allocates them on each hit ?
I cannot compile php from sources. But if anyone can point me to a
debug build I can try that with memleak detection on.
Best regards,
Nicolai Petri
Previous Comments:
------------------------------------------------------------------------
[2002-11-25 12:01:44] tgl at tgltech dot dk
Seems this bug still exists in the 4.2.3 ISAPI. I'm running on Windows
2000 Advanced Server with IIS 5.0.
I recently moved to ISAPI instead of CGI as I upgraded from 4.2.1. A
week ago I noticed extreme RAM usage. The sites on the server only have
< 50 hits / day, so the bug does not require heavy load to appear.
I tested it on a page showing phpinfo() and it added 1-2 MB per
request.
Restarting IIS frees the memory, but that's not really an option.
I've tested the latest CVS snapshot and it appears to have the same
bug.
------------------------------------------------------------------------
[2002-10-26 01:00:06] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2002-10-10 22:58:07] iliaa@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
------------------------------------------------------------------------
[2002-06-09 08:37:03] abo at irgendware dot com
I have the same problem using IIS5.1 with WinXP Pro with PHP4.2.1 as
ISAPI module.
During 2 seconds 300 MB of RAM where reservated for the service. I had
to stop and restart all services and IIS admin to get the memory back.
------------------------------------------------------------------------
[2002-03-27 23:06:39] mail-php dot net at kimihia dot org dot nz
The setup:
IIS5 has an ISAPI application mapping to php4isapi.dll
Steps to reproduce:
- Start IIS
- Generate heavy load (~40+ hits / second)
- Watch DLLHOST in the Task Manager. It takes more and more memory (40
- 45MB)
- PHP error log begins reporting spurious errors (the page has no
errors, but under heavy load it starts complaining about duplicate
function definitions) Bug: #13324
- IIS stops serving PHP files but still serves static content
DLLHOST disappears from the task list at this point.
Other times it may begin taking 100% CPU and need to be terminated by
hand.
Killing DLLHOST usually causes it to be restarted and requests continue
being served. Otherwise you may end up alternating between the two
errors on bug #13324.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16325&edit=1