Bug #16325 Updated: Memory leak causes DLLHOST to become large
| From: | abo at irgendware dot com | Date: | Sun, 09 Jun 2002 12:37:03 +0000 |
| Subject: | Bug #16325 Updated: Memory leak causes DLLHOST to become large | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-9922@lists.php.net to get a copy of this message | ||
ID: 16325
Updated by: abo@irgendware.com
Reported By: mail-php.net@kimihia.org.nz
Status: Open
Bug Type: IIS related
Operating System: Windows 2000 Server
PHP Version: 4.1.2
New Comment:
I have the same problem using IIS5.1 with WinXP Pro with PHP4.2.1 as
ISAPI module.
During 2 seconds 300 MB of RAM where reservated for the service. I had
to stop and restart all services and IIS admin to get the memory back.
Previous Comments:
------------------------------------------------------------------------
[2002-03-27 23:06:39] mail-php.net@kimihia.org.nz
The setup:
IIS5 has an ISAPI application mapping to php4isapi.dll
Steps to reproduce:
- Start IIS
- Generate heavy load (~40+ hits / second)
- Watch DLLHOST in the Task Manager. It takes more and more memory (40
- 45MB)
- PHP error log begins reporting spurious errors (the page has no
errors, but under heavy load it starts complaining about duplicate
function definitions) Bug: #13324
- IIS stops serving PHP files but still serves static content
DLLHOST disappears from the task list at this point.
Other times it may begin taking 100% CPU and need to be terminated by
hand.
Killing DLLHOST usually causes it to be restarted and requests continue
being served. Otherwise you may end up alternating between the two
errors on bug #13324.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16325&edit=1