#23300 [NEW]: Sporadic PHP page load failures with "Initialized PHP Module" in error log
| From: | folsomke at plu dot edu | Date: | Mon, 21 Apr 2003 23:35:45 +0000 |
| Subject: | #23300 [NEW]: Sporadic PHP page load failures with "Initialized PHP Module" in error log | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-38021@lists.php.net to get a copy of this message | ||
From: folsomke at plu dot edu
Operating system: Tru64 4.0f
PHP version: 4.3.1
PHP Bug Type: iPlanet related
Bug description: Sporadic PHP page load failures with "Initialized PHP Module" in error
log
I am configuring PHP 4.3.1 with the following:
./configure \
--with-mysql \
--with-nsapi=/apps/netscape/server4/ \
--enable-track-vars \
--with-ldap=/usr/local \
--without-pear \
--with-openssl=/usr/local/ssl
LDAP is the Netscape 3.0 SDK. SSL is OpenSSL 0.9.7. The web server is
iPlanet Enterprise server version 4.1SP9. The compiler is cc (though I
also tried using gcc 2.95.3 and had the same problem as reported below).
The compile and install of PHP work well. I've modified my web server
config files according to instructions in the PHP manual for version 4.x
of the iPlanet web server. The web server starts fine and serves up PHP
pages with no problems most the time. But, occasionally, upon trying to
load a PHP page, my web browser will report "The document contained no
data." Loading the document a second time usually brings it up normally.
Looking at the web server error log shows the following message is
reported when the page fails to load:
php4_init reports: Initialized PHP Module
It looks like the PHP page request is causing the iPlanet web server
process to crash. When the watchdog process re-starts the web server
process, the PHP module is re-initialized.
I have seen some older references to this same problem in the bug archive,
but these have not indicated any solutions. Thanks much for your help.
--
Edit bug report at http://bugs.php.net/?id=23300&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=23300&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=23300&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=23300&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=23300&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=23300&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=23300&r=support
Expected behavior: http://bugs.php.net/fix.php?id=23300&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=23300&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=23300&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=23300&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=23300&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=23300&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=23300&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=23300&r=gnused