#23300 [Fbk->Opn]: Sporadic PHP page load failures with "Initialized PHP Module" in error log

From: Date: Tue, 22 Apr 2003 16:11:16 +0000
Subject: #23300 [Fbk->Opn]: Sporadic PHP page load failures with "Initialized PHP Module" in error log
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-38068@lists.php.net to get a copy of this message
ID: 23300 User updated by: folsomke at plu dot edu Reported By: folsomke at plu dot edu -Status: Feedback +Status: Open Bug Type: iPlanet related Operating System: Tru64 4.0f PHP Version: 4.3.1 New Comment: Thanks for the test kit. I'll compile it and give it a try. I'll report back if I see the problem again, or, if it's stable for several days, I'll report this, as well. Previous Comments: ------------------------------------------------------------------------ [2003-04-21 20:56:01] magnus@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-STABLE-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-STABLE-latest.zip ------------------------------------------------------------------------ [2003-04-21 18:35:45] folsomke at plu dot edu I am configuring PHP 4.3.1 with the following: ./configure \ --with-mysql \ --with-nsapi=/apps/netscape/server4/ \ --enable-track-vars \ --with-ldap=/usr/local \ --without-pear \ --with-openssl=/usr/local/ssl LDAP is the Netscape 3.0 SDK. SSL is OpenSSL 0.9.7. The web server is iPlanet Enterprise server version 4.1SP9. The compiler is cc (though I also tried using gcc 2.95.3 and had the same problem as reported below). The compile and install of PHP work well. I've modified my web server config files according to instructions in the PHP manual for version 4.x of the iPlanet web server. The web server starts fine and serves up PHP pages with no problems most the time. But, occasionally, upon trying to load a PHP page, my web browser will report "The document contained no data." Loading the document a second time usually brings it up normally. Looking at the web server error log shows the following message is reported when the page fails to load: php4_init reports: Initialized PHP Module It looks like the PHP page request is causing the iPlanet web server process to crash. When the watchdog process re-starts the web server process, the PHP module is re-initialized. I have seen some older references to this same problem in the bug archive, but these have not indicated any solutions. Thanks much for your help. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=23300&edit=1

« previous php.bugs (#38068) next »