#23474 [NEW]: OCI8 loads when apache started from cmd, not when apache started as service

From: Date: Sun, 04 May 2003 03:28:28 +0000
Subject: #23474 [NEW]: OCI8 loads when apache started from cmd, not when apache started as service
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-39009@lists.php.net to get a copy of this message
From: deepblah at yahoo dot com Operating system: Windows 2000 PHP version: 4.3.1 PHP Bug Type: OCI8 related Bug description: OCI8 loads when apache started from cmd, not when apache started as service Okay, this one starts out as most of the other OCI8-related bogus bugs. But in my opinion, this seems to be a 'real' bug. Here goes: I have Apache 1.3.27, Oracle 8i EE and PHP 4.3.1 installed on a Windows 2000 system. PHP and Apache worked fine, until I decided to go enable the OCI8 extension. Even after making sure of the following: 1) extension_dir = "C:\php\extensions" 2) oci.dll in %PATH% apache would complain: PHP Warning: Unknown(): Unable to load dynamic library 'c:\php\extensions\php_oci8.dll' - The specified module could not be found. in Unknown on line 0 Apache ran (w/o loading OCI8) however. Following the advice in one of the other posts, I enabled php_exif.dll and that loaded fine. Eventually, I started apache from commandline, w/o any options and it started fine, and loaded OCI8. (phpinfo() confirmed that.) But again, when I tried to start apache with the default options, [apache -w -n "Apache" -k start] which essencially starts the service, it popped up the same error. phpinfo() confirmed that OCI8 wasn't loaded. -- Edit bug report at http://bugs.php.net/?id=23474&edit=1 -- Try a CVS snapshot: http://bugs.php.net/fix.php?id=23474&r=trysnapshot Fixed in CVS: http://bugs.php.net/fix.php?id=23474&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=23474&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=23474&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=23474&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=23474&r=support Expected behavior: http://bugs.php.net/fix.php?id=23474&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=23474&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=23474&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=23474&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=23474&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=23474&r=dst IIS Stability: http://bugs.php.net/fix.php?id=23474&r=isapi Install GNU Sed: http://bugs.php.net/fix.php?id=23474&r=gnused

« previous php.bugs (#39009) next »