#23474 [Opn->Bgs]: OCI8 loads when apache started from cmd, not when apache started as service
| From: | sniper@php.net | Date: | Mon, 05 May 2003 21:42:47 +0000 |
| Subject: | #23474 [Opn->Bgs]: OCI8 loads when apache started from cmd, not when apache started as service | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-39111@lists.php.net to get a copy of this message | ||
ID: 23474
Updated by: sniper@php.net
Reported By: deepblah at yahoo dot com
-Status: Open
+Status: Bogus
Bug Type: OCI8 related
Operating System: Windows 2000
PHP Version: 4.3.1
New Comment:
If it works -> bogus.
Previous Comments:
------------------------------------------------------------------------
[2003-05-04 18:17:58] deepblah at yahoo dot com
An update.
The service works now, although I haven't changed anything. I am
leaving this bug open, so the developer(s) can look into it regardless,
if they wish to.
------------------------------------------------------------------------
[2003-05-03 22:28:28] deepblah at yahoo dot com
Okay, this one starts out as most of the other OCI8-related bogus bugs.
But in my opinion, this seems to be a 'real' bug. Here goes:
I have Apache 1.3.27, Oracle 8i EE and PHP 4.3.1 installed on a Windows
2000 system. PHP and Apache worked fine, until I decided to go enable
the OCI8 extension. Even after making sure of the following:
1) extension_dir = "C:\php\extensions"
2) oci.dll in %PATH%
apache would complain:
PHP Warning: Unknown(): Unable to load dynamic library
'c:\php\extensions\php_oci8.dll' - The specified module could not be
found.
in Unknown on line 0
Apache ran (w/o loading OCI8) however.
Following the advice in one of the other posts, I enabled php_exif.dll
and that loaded fine.
Eventually, I started apache from commandline, w/o any options and it
started fine, and loaded OCI8. (phpinfo() confirmed that.)
But again, when I tried to start apache with the default options,
[apache -w -n "Apache" -k start] which essencially starts the service,
it popped up the same error. phpinfo() confirmed that OCI8 wasn't
loaded.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=23474&edit=1