#21653 [Fbk->NoF]: Warning: fsockopen() [function.fsockopen]: php_hostconnect: connect failed

From: Date: Fri, 09 May 2003 12:25:56 +0000
Subject: #21653 [Fbk->NoF]: Warning: fsockopen() [function.fsockopen]: php_hostconnect: connect failed
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-39365@lists.php.net to get a copy of this message
 ID:               21653
 Updated by:       sniper@php.net
 Reported By:      support at hostcolor dot com
-Status:           Feedback
+Status:           No Feedback
 Bug Type:         Sockets related
 Operating System: RedHat 7.2
 PHP Version:      4.3.0
 New Comment:

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.




Previous Comments:
------------------------------------------------------------------------

[2003-05-05 13:39:43] laudanp at yahoo dot com

My issue still hasn't been resolved because we still haven't traveled
down your recommended path.  Someone at my provider is looking into
this for me.

------------------------------------------------------------------------

[2003-04-28 06:29:00] wez@php.net

Also, this item from the NEWS file is also relevant:
- Added php.ini option "default_socket_timeout" to set the
  timeout limit for PHP network streams.
 (kalowsky, ilia@prohost.org, Wez)

The default value is 60 seconds (it was introduced to avoid DoS
attacks).

You can set this value from your scripts as well in the ini or
httpd.conf. (see docs for ini_alter).

------------------------------------------------------------------------

[2003-04-28 06:23:40] wez@php.net

How long does it take to produce the error message?
You are specifying a timeout of 30 seconds; if it takes longer than 30
seconds, PHP will abort the connection attempt, even if it is "in
progress".

------------------------------------------------------------------------

[2003-04-28 06:14:19] insyderhomielc at hotmail dot com

Just putting in my two cents... suddenly SquirrelMail doesn't run
because of this error.  Please get this bug fix in soon.  Thanks.

------------------------------------------------------------------------

[2003-04-15 16:04:37] jim at revjim dot net

This is now a problem for me as well. I am running PHP 4.2.3 under
Linux. When I was using the built in MySQL libraries, this was not an
issue. However, now that I've recompiled (same apache version, same PHP
version) I am showing the same problem. Restarting Apache seems to
correct it temporarily.

(Apache 1.3.27, Mysql 4.0.12, PHP 4.2.3)

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/21653

-- 
Edit this bug report at http://bugs.php.net/?id=21653&edit=1



Thread (57 messages)

« previous php.bugs (#39365) next »