#21653 [Com]: Warning: fsockopen() [function.fsockopen]: php_hostconnect: connect failed
| From: | sosingus at yahoo dot com | Date: | Wed, 28 Jun 2006 09:08:42 +0000 |
| Subject: | #21653 [Com]: Warning: fsockopen() [function.fsockopen]: php_hostconnect: connect failed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-98882@lists.php.net to get a copy of this message | ||
ID: 21653
Comment by: sosingus at yahoo dot com
Reported By: support at hostcolor dot com
Status: No Feedback
Bug Type: Sockets related
Operating System: RedHat 7.2
PHP Version: 4.3.3RC2-dev
New Comment:
I have a similar problem using php 4.4.1 with pfsockopen
Part of code:
------------------
<?php
$fp = pfsockopen("ssl://example.com", 443, $errno, $errstr);
if (!$fp){
echo "$errstr ($errno)<br>\n";
exit;
}
?>
Output:
------------------
Operation now in progress (115)
Modules:
------------------
'./configure' '--with-gd' '--with-msql=/usr/local/msql2.0'
'--with-mysql=/usr/local/mysql' '--with-apache=../apache_1.3.34'
'--with-jpeg-dir=/usr/lib' '--with-png-dir=/usr/lib' '--with-mhash'
'--with-openssl=/usr/local/ssl' '--enable-ftp' '--enable-imap'
'--with-zlib-dir=/usr/local/lib' '--with-pear'
'--with-curl=/usr/local/lib' '--with-pear=../PEAR-1.1'
'--enable-mbstring=all' '--with-dom=/usr/local'
'--with-domxml=/usr/local' '--enable-memory-limit=yes'
'--enable-sockets' '--with-gd-native-ttf' '--enable-gd-imgstrttf'
'--with-freetype-dir=/usr/local' '--enable-shared'
'--with-expat-dir=/usr/local' '--with-dom-xslt=/usr/local'
'--with-xslt-sablot'
Additional info
--------------------
I have it working on another domain and server with php 4.3.4
Previous Comments:
------------------------------------------------------------------------
[2005-01-05 12:50:42] suhailc at gmail dot com
Hi,
I get the following error:
Warning: fsockopen(): unable to connect to whois.crsnic.net:43 in
/home/ecompco/public_html/test.php on line 2
Could not open connection
However, the connection is made perfectly and fast when I switch off
APF. I get:
Connected OK.
For the life of me I cannot figure out why - I've added ports 43, 443,
4343, 80 to conf.php but still error shows when APF is on. But it does
have something to do with APF.
Regards,
Suhail.
------------------------------------------------------------------------
[2003-07-23 21:16:30] laudanp at yahoo dot com
I opened a new bug report here:
http://bugs.php.net/bug.php?id=24785
------------------------------------------------------------------------
[2003-07-23 14:44:48] laudanp at yahoo dot com
re: "No feedback from original bug submitter.
laudanp at yahoo dot com:
If you still feel this is a bug, open new report with
short example script, expected result and got result."
Thanks for replying to me. I'll go ahead and open a new ticket while
referencing this one for posterity. Look for it tonight.
------------------------------------------------------------------------
[2003-07-23 14:31:25] laudanp at yahoo dot com
Hi I provided the feedback above, I'm still having those problems.
Help
------------------------------------------------------------------------
[2003-07-18 18:53:18] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
No feedback from original bug submitter.
laudanp at yahoo dot com:
If you still feel this is a bug, open new report with
short example script, expected result and got result.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/21653
--
Edit this bug report at http://bugs.php.net/?id=21653&edit=1