Bug #16416: Unable to load Dynamic Libraries when mod_ssl enabled
| From: | php at hawkfans dot com | Date: | Wed, 03 Apr 2002 21:56:12 +0000 |
| Subject: | Bug #16416: Unable to load Dynamic Libraries when mod_ssl enabled | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-3958@lists.php.net to get a copy of this message | ||
From: php@hawkfans.com
Operating system: RedHat Linux 7.0
PHP version: 4.1.2
PHP Bug Type: Apache related
Bug description: Unable to load Dynamic Libraries when mod_ssl enabled
I'm running Apache 1.3.24, ModSSL 2.8.8, and PHP 4.1.2. For some reason,
whenever I enable mod_ssl in Apache, I receive the following errors in my
error_log file:
PHP Warning: Unable to load dynamic library '/usr/local/lib/imap.so' -
/usr/local/lib/imap.so: cannot open shared object file: No such file or
directory in Unknown on line 0
PHP Warning: Unable to load dynamic library '/usr/local/lib/ldap.so' -
/usr/local/lib/ldap.so: cannot open shared object file: No such file or
directory in Unknown on line 0
PHP Warning: Unable to load dynamic library '/usr/local/lib/mysql.so' -
/usr/local/lib/mysql.so: cannot open shared object file: No such file or
directory in Unknown on line 0
Here's how everything's configured:
mod_ssl:
./configure --with-apache=../apache_1.3.24 --with-ssl=../openssl-0.9.6c
--with-crt=/usr/share/ssl/certs/server.crt
--with-key=/usr/share/ssl/certs/server.key --prefix=/usr/local/apache
apache:
SSL_BASE=/tmp/openssl-0.9.6c ./configure --prefix=/usr/local/apache
--server-uid=apache --server-gid=apache --enable-module=ssl
--enable-module=so
php:
./configure --with-apxs=/usr/local/apache/bin/apxs --enable-calendar
--with-imap --with-mysql --with-kerberos --with-imap-ssl
But, like I said, when I uncomment these lines in httpd.conf,
#Include conf/ssl/mod_ssl.conf
#Include conf/ssl/ssl.vhosts.conf
I get the unable to load dynamic libraries messages...
Any help that you can render would be greatly appreciated
--
Edit bug report at http://bugs.php.net/?id=16416&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=16416&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=16416&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=16416&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=16416&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=16416&r=support
Expected behavior: http://bugs.php.net/fix.php?id=16416&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=16416&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=16416&r=submittedtwice