Bug #16416 Updated: Unable to load Dynamic Libraries when mod_ssl enabled
| From: | sniper@php.net | Date: | Wed, 03 Apr 2002 23:51:32 +0000 |
| Subject: | Bug #16416 Updated: Unable to load Dynamic Libraries when mod_ssl enabled | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-3969@lists.php.net to get a copy of this message | ||
ID: 16416
Updated by: sniper@php.net
Reported By: php@hawkfans.com
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: RedHat Linux 7.0
PHP Version: 4.1.2
New Comment:
First: DO NOT use source paths, use the install prefixes.
ie. if openssl libraries exist in /www/openssl/lib you
would use --with-openssl=/www/openssl and --with-imap-ssl=/www/openssl
And did I understand correctly that you don't even have imap.so /
ldap.so / mysql.so anywhere in your system?
If this assumption is correct, why do you load them
in php.ini ???
--Jani
Previous Comments:
------------------------------------------------------------------------
[2002-04-03 18:26:06] php@hawkfans.com
Okay, I recompiled with this config line:
./configure --with-apxs=/usr/local/apache/bin/apxs
--with-openssl=../openssl-0.9.6c --enable-calendar --with-imap
--with-mysql --with-kerberos --with-imap-ssl
../openssl-0.9.6c is the source dir that I used when I compiled
mod_ssl.
as far as the external modules, As far as I know, I've never had those
on this server. (I did a search and they were nowhere to be found on
the server). I've compiled PHP this way a couple of times already on
this server when performing upgrades.
------------------------------------------------------------------------
[2002-04-03 17:15:20] sniper@php.net
And that configure line for PHP does NOT produce any shared
extensions. Are you sure you're not using some old versions
of those extensions?
------------------------------------------------------------------------
[2002-04-03 17:14:06] sniper@php.net
Are you compiling PHP with the same SSL libs as the mod_ssl
is compiled with? Only passing '--with-imap-ssl' will assume
/usr as the install prefix for ssl libraries.
--Jani
------------------------------------------------------------------------
[2002-04-03 16:56:10] php@hawkfans.com
I'm running Apache 1.3.24, ModSSL 2.8.8, and PHP 4.1.2. For some
reason, whenever I enable mod_ssl in Apache, I receive the following
errors in my error_log file:
PHP Warning: Unable to load dynamic library '/usr/local/lib/imap.so' -
/usr/local/lib/imap.so: cannot open shared object file: No such file or
directory in Unknown on line 0
PHP Warning: Unable to load dynamic library '/usr/local/lib/ldap.so' -
/usr/local/lib/ldap.so: cannot open shared object file: No such file or
directory in Unknown on line 0
PHP Warning: Unable to load dynamic library '/usr/local/lib/mysql.so'
- /usr/local/lib/mysql.so: cannot open shared object file: No such file
or directory in Unknown on line 0
Here's how everything's configured:
mod_ssl:
./configure --with-apache=../apache_1.3.24 --with-ssl=../openssl-0.9.6c
--with-crt=/usr/share/ssl/certs/server.crt
--with-key=/usr/share/ssl/certs/server.key --prefix=/usr/local/apache
apache:
SSL_BASE=/tmp/openssl-0.9.6c ./configure --prefix=/usr/local/apache
--server-uid=apache --server-gid=apache --enable-module=ssl
--enable-module=so
php:
./configure --with-apxs=/usr/local/apache/bin/apxs --enable-calendar
--with-imap --with-mysql --with-kerberos --with-imap-ssl
But, like I said, when I uncomment these lines in httpd.conf,
#Include conf/ssl/mod_ssl.conf
#Include conf/ssl/ssl.vhosts.conf
I get the unable to load dynamic libraries messages...
Any help that you can render would be greatly appreciated
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16416&edit=1