#23776 [NEW]: --with-regex=apache makes apache unable to resolve 'php_regcomp' when starting.
| From: | kostya at defender dot ru | Date: | Fri, 23 May 2003 12:49:06 +0000 |
| Subject: | #23776 [NEW]: --with-regex=apache makes apache unable to resolve 'php_regcomp' when starting. | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-40266@lists.php.net to get a copy of this message | ||
From: kostya at defender dot ru
Operating system: Linux-2.4.20, glibc-2.1.2
PHP version: 4.3.2RC4
PHP Bug Type: Dynamic loading
Bug description: --with-regex=apache makes apache unable to resolve 'php_regcomp' when
starting.
If I compile PHP as apache's module, using 'apache' regex, then Apache
fails to start complaining:
-- Cannot load /usr/apache/lib/libphp4.so into server:
/usr/apache/lib/libphp4.so: undefined symbol: php_regcomp
The other 'configure' options does not affect this problem. Specifically,
'configure' may be:
./configure --prefix=/usr \
--with-apxs=/usr/apache/apxs \
--with-regex=apache \
--disable-all --disable-cgi --disable-cli --disable-ipv6
My apache configuration seems relevant to this issue:
- apache-1.3.27, patched with
- mod_ssl-2.4.18.
Apache compile-time 'configure' options include
--disable-rule=WANTHSREGEX. This forces apache not to use bundled regex
library, but use 'system' regex instead.
The same problem was also observed with prior 4.3.2RC3 PHP release
candidate.
Yes, I know that workaround is to indicate '--with-regex=php', and use
bundled regex library. But... what shared libraries exists for ?
--
Edit bug report at http://bugs.php.net/?id=23776&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=23776&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=23776&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=23776&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=23776&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=23776&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=23776&r=support
Expected behavior: http://bugs.php.net/fix.php?id=23776&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=23776&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=23776&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=23776&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=23776&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=23776&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=23776&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=23776&r=gnused