#23776 [Opn->Bgs]: --with-regex=apache makes apache unable to resolve 'php_regcomp' when starting.
| From: | derick@php.net | Date: | Fri, 23 May 2003 12:53:02 +0000 |
| Subject: | #23776 [Opn->Bgs]: --with-regex=apache makes apache unable to resolve 'php_regcomp' when starting. | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-40267@lists.php.net to get a copy of this message | ||
ID: 23776
Updated by: derick@php.net
Reported By: kostya at defender dot ru
-Status: Open
+Status: Bogus
Bug Type: Dynamic loading
Operating System: Linux-2.4.20, glibc-2.1.2
PHP Version: 4.3.2RC4
New Comment:
./configure --help shows:
--with-regex=TYPE regex library type: system, apache, php.
Default: php
WARNING: Do NOT use unless you know what you
are doing!
Don't touch it.
Previous Comments:
------------------------------------------------------------------------
[2003-05-23 07:49:06] kostya at defender dot ru
If I compile PHP as apache's module, using 'apache' regex, then Apache
fails to start complaining:
-- Cannot load /usr/apache/lib/libphp4.so into server:
/usr/apache/lib/libphp4.so: undefined symbol: php_regcomp
The other 'configure' options does not affect this problem.
Specifically, 'configure' may be:
./configure --prefix=/usr \
--with-apxs=/usr/apache/apxs \
--with-regex=apache \
--disable-all --disable-cgi --disable-cli --disable-ipv6
My apache configuration seems relevant to this issue:
- apache-1.3.27, patched with
- mod_ssl-2.4.18.
Apache compile-time 'configure' options include
--disable-rule=WANTHSREGEX. This forces apache not to use bundled regex
library, but use 'system' regex instead.
The same problem was also observed with prior 4.3.2RC3 PHP release
candidate.
Yes, I know that workaround is to indicate '--with-regex=php', and use
bundled regex library. But... what shared libraries exists for ?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=23776&edit=1