#23847 [NEW]: ../libphp4.so: invalid ELF header
| From: | eddie at rola dot ch | Date: | Wed, 28 May 2003 10:48:35 +0000 |
| Subject: | #23847 [NEW]: ../libphp4.so: invalid ELF header | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-40563@lists.php.net to get a copy of this message | ||
From: eddie at rola dot ch
Operating system: SuSE Linux Prof. 8.0
PHP version: 4.3.2RC4
PHP Bug Type: *Configuration Issues
Bug description: ../libphp4.so: invalid ELF header
After installing Apache 2.0.46 on the
Webserver (--enable-so --with-layout=SuSE) and PHP 4.3.2RC4
(--with-apxs2=/usr/sbin/apxs) no warnings or failure messages has benn
showed. The Configuration file of Apache had a wrong path of the
libphp4.so (LoadModule). After I've changed it the failure message came by
starting the webserver (Check Summary). Here the whole message:
Cannot load /usr/lib/libphp4.so into server: invalid EFL header
PS:I had no failure message before (like: cannot find libphp4.so) but the
file can't be there [/usr/lib/apache/libphp4.do] because I don't have that
file. After all php doesn't work without any failure messages.
--
Edit bug report at http://bugs.php.net/?id=23847&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=23847&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=23847&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=23847&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=23847&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=23847&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=23847&r=support
Expected behavior: http://bugs.php.net/fix.php?id=23847&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=23847&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=23847&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=23847&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=23847&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=23847&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=23847&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=23847&r=gnused