#23847 [Opn->Fbk]: ../libphp4.so: invalid ELF header
| From: | sniper@php.net | Date: | Wed, 28 May 2003 13:55:04 +0000 |
| Subject: | #23847 [Opn->Fbk]: ../libphp4.so: invalid ELF header | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-40573@lists.php.net to get a copy of this message | ||
ID: 23847
Updated by: sniper@php.net
Reported By: eddie at rola dot ch
-Status: Open
+Status: Feedback
-Bug Type: *Configuration Issues
+Bug Type: Compile Failure
Operating System: SuSE Linux Prof. 8.0
PHP Version: 4.3.2RC4
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
And don't try fixing anything in any configure file under the
php4*/ directory.
I'm 100% sure this is not any bug in PHP though, you're just doing
something wrong there. (I just compiled the latest CVS snapshot with
apache2 and it worked fine.)
It's propably SuSE again that is broken here.
Previous Comments:
------------------------------------------------------------------------
[2003-05-28 05:48:35] eddie at rola dot ch
After installing Apache 2.0.46 on the
Webserver (--enable-so --with-layout=SuSE) and PHP 4.3.2RC4
(--with-apxs2=/usr/sbin/apxs) no warnings or failure messages has benn
showed. The Configuration file of Apache had a wrong path of the
libphp4.so (LoadModule). After I've changed it the failure message came
by starting the webserver (Check Summary). Here the whole message:
Cannot load /usr/lib/libphp4.so into server: invalid EFL header
PS:I had no failure message before (like: cannot find libphp4.so) but
the file can't be there [/usr/lib/apache/libphp4.do] because I don't
have that file. After all php doesn't work without any failure
messages.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=23847&edit=1