#24426 [NEW]: Installation Doesn't Work
From: LouisGreen at pljg dot freeserve dot co dot uk
Operating system: Windows XP Pro
PHP version: 5.0.0b1 (beta1)
PHP Bug Type: *Web Server problem
Bug description: Installation Doesn't Work
Description:
------------
I have tried without success to get php-5.0.0b1-Win32 installed. The web
servers I have tried with are:
Apache 1.3.27
Apache 2.0.46
I tried following the PHP 4 instructions for installing PHP 5, both as a
Module and CGI, but Apache refuses to start up. This is what I have put in
to the config httpd.conf file for the server:
LoadModule php4_module C:/Apache2/PHP5/sapi/php4apache2.dll
AddType application/x-httpd-php .php
or
LoadModule php5_module C:/Apache2/PHP5/sapi/php4apache2.dll
AddType application/x-httpd-php .php
I have also copied the php4ts.dll file to the Windows/Winnt and system32
driectories. Also the php.ini file to the windows/winnt directory. Then
when I start Apache, I get this error:
Syntax error on line 176 of C:/Apache2/conf/httpd.conf
Cannot load C:/Apache2/PHP5/sapi/php4apache2.dll into server. The
specified module could not be found
-----------------------------------------------------------
I also tried PHP 4.3.2 and it on Apache 1.3.27 & 2.0.46 using:
#LoadModule php4_module C:/Apache2/PHP4/sapi/php4apache.dll
LoadModule php4_module C:/Apache2/PHP4/sapi/php4apache2.dll
AddType application/x-httpd-php .php
with success (of course using the right apache file and php4ts.dll).
I know I can get PHP 4 working with a clean install, but not PHP 5 :-S
Expected result:
----------------
To work :'(
Actual result:
--------------
Syntax error on line 176 of C:/Apache2/conf/httpd.conf
Cannot load C:/Apache2/PHP5/sapi/php4apache2.dll into server. The
specified module could not be found
--
Edit bug report at http://bugs.php.net/?id=24426&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=24426&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=24426&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=24426&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=24426&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=24426&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=24426&r=support
Expected behavior: http://bugs.php.net/fix.php?id=24426&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=24426&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=24426&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=24426&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=24426&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=24426&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=24426&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=24426&r=gnused
Thread (9 messages)
- LouisGreen at pljg dot freeserve dot co dot uk