#24426 [Opn]: Installation Doesn't Work

From: Date: Mon, 30 Jun 2003 22:53:13 +0000
Subject: #24426 [Opn]: Installation Doesn't Work
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-42937@lists.php.net to get a copy of this message
ID: 24426 User updated by: LouisGreen at pljg dot freeserve dot co dot uk Reported By: LouisGreen at pljg dot freeserve dot co dot uk Status: Open Bug Type: *Web Server problem Operating System: Windows XP Pro PHP Version: 5.0.0b1 (beta1) New Comment: err, slight tpyo, but did do a complete refresh install of apache 1 and 2. And I did complete uninstalled and removed the old apache directory each time, so the remains of the old one left. Should of typed for the working bit #LoadModule php4_module C:/Apache/PHP4/sapi/php4apache.dll LoadModule php4_module C:/Apache2/PHP4/sapi/php4apache2.dll AddType application/x-httpd-php .php Previous Comments: ------------------------------------------------------------------------ [2003-06-30 17:44:16] LouisGreen at pljg dot freeserve dot co dot uk Description: ------------ I have tried without success to get php-5.0.0b1-Win32 installed. The web servers I have tried with are: Apache 1.3.27 Apache 2.0.46 I tried following the PHP 4 instructions for installing PHP 5, both as a Module and CGI, but Apache refuses to start up. This is what I have put in to the config httpd.conf file for the server: LoadModule php4_module C:/Apache2/PHP5/sapi/php4apache2.dll AddType application/x-httpd-php .php or LoadModule php5_module C:/Apache2/PHP5/sapi/php4apache2.dll AddType application/x-httpd-php .php I have also copied the php4ts.dll file to the Windows/Winnt and system32 driectories. Also the php.ini file to the windows/winnt directory. Then when I start Apache, I get this error: Syntax error on line 176 of C:/Apache2/conf/httpd.conf Cannot load C:/Apache2/PHP5/sapi/php4apache2.dll into server. The specified module could not be found ----------------------------------------------------------- I also tried PHP 4.3.2 and it on Apache 1.3.27 & 2.0.46 using: #LoadModule php4_module C:/Apache2/PHP4/sapi/php4apache.dll LoadModule php4_module C:/Apache2/PHP4/sapi/php4apache2.dll AddType application/x-httpd-php .php with success (of course using the right apache file and php4ts.dll). I know I can get PHP 4 working with a clean install, but not PHP 5 :-S Expected result: ---------------- To work :'( Actual result: -------------- Syntax error on line 176 of C:/Apache2/conf/httpd.conf Cannot load C:/Apache2/PHP5/sapi/php4apache2.dll into server. The specified module could not be found ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=24426&edit=1

« previous php.bugs (#42937) next »