#24664 [NEW]: relocation error: symbol not found: ap_pass_brigade
From: a dot polli at mir dot it
Operating system: OpenUnix 8
PHP version: 4.3.2
PHP Bug Type: Dynamic loading
Bug description: relocation error: symbol not found: ap_pass_brigade
Description:
------------
I have this error when I start apache2 (2.0.46) with php4 (4.3.2)
Syntax error on line 233 of /mypath/apache2/conf/httpd.conf:
Cannot load /mypath/apache2/modules/libphp4.so into server: dynamic
linker:
/mypath/apache2/bin/httpd: relocation error: symbol not found:
ap_pass_brigade; referenced from: /mypath/apache2/modules/libphp4.so
I compile apache 2.0.46 with
./configure --prefix=/mypath/apache2
--enable-modules="ssl dav mime-magic
auth-anon auth-dbm auth-digest cern-meta expires headers usertrack
unique-id
proxy info cgi vhost-alias rewrite so speling"
and then php 4.3.2 with
./configure --with-apxs2=/mypath/apache2/bin/apxs
--with-pgsql=/mypath/pgsql
--with-mysql=/mypath/mysql
--with-zlib
--with-gd
--with-ftp
--with-xml
--
Edit bug report at http://bugs.php.net/?id=24664&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=24664&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=24664&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=24664&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=24664&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=24664&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=24664&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=24664&r=support
Expected behavior: http://bugs.php.net/fix.php?id=24664&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=24664&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=24664&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=24664&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=24664&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=24664&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=24664&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=24664&r=gnused
Thread (10 messages)
- a dot polli at mir dot it