#24664 [Opn->Fbk]: relocation error: symbol not found: ap_pass_brigade
ID: 24664
Updated by: sniper@php.net
Reported By: a dot polli at mir dot it
-Status: Open
+Status: Feedback
-Bug Type: Dynamic loading
+Bug Type: Apache2 related
Operating System: OpenUnix 8
PHP Version: 4.3.2
New Comment:
Have you tried Apache 1.3.27 which might actually work?
Previous Comments:
------------------------------------------------------------------------
[2003-07-16 03:15:30] a dot polli at mir dot it
I try it (php4-STABLE-200307160530),
but I have the same error when I start apache2.
------------------------------------------------------------------------
[2003-07-15 13:27:51] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2003-07-15 08:30:10] a dot polli at mir dot it
Description:
------------
I have this error when I start apache2 (2.0.46) with php4 (4.3.2)
Syntax error on line 233 of /mypath/apache2/conf/httpd.conf:
Cannot load /mypath/apache2/modules/libphp4.so into server: dynamic
linker:
/mypath/apache2/bin/httpd: relocation error: symbol not found:
ap_pass_brigade; referenced from: /mypath/apache2/modules/libphp4.so
I compile apache 2.0.46 with
./configure --prefix=/mypath/apache2
--enable-modules="ssl dav mime-magic
auth-anon auth-dbm auth-digest cern-meta expires headers usertrack
unique-id
proxy info cgi vhost-alias rewrite so speling"
and then php 4.3.2 with
./configure --with-apxs2=/mypath/apache2/bin/apxs
--with-pgsql=/mypath/pgsql
--with-mysql=/mypath/mysql
--with-zlib
--with-gd
--with-ftp
--with-xml
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24664&edit=1
Thread (10 messages)