#25251 [NEW]: starting apache after compile with postgres fails!

From: Date: Tue, 26 Aug 2003 12:06:36 +0000
Subject: #25251 [NEW]: starting apache after compile with postgres fails!
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-46674@lists.php.net to get a copy of this message
From: necmon at gmx dot de Operating system: Suse Linux 7.2 PHP version: 4.3.3 PHP Bug Type: Compile Failure Bug description: starting apache after compile with postgres fails! Description: ------------ my configure line: './configure' '--bindir=/usr/bin' '--libdir=/usr/lib' '--with-config-file-path=/etc' '--with-exec-dir=%{libdir}/php/bin' '--with-gd=yes' '--with-tiff-dir=/usr' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-pdflib=/usr' '--with-ldap=yes' '--with-zlib=yes' '--with-bz2' '--with-ttf' '--with-xml=no' '--with-t1lib' '--with-sablot' '--with-readline' '--with-ftp' '--with-ndbm' '--with-gdbm' '--with-mcrypt' '--with-gettext' '--with-mm' '--with-gd=yes' '--enable-versioning' '--enable-yp' '--enable-bcmath' '--enable-trans-sid' '--enable-inline-optimization' '--enable-track-vars' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-shmop' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-memory-limit' '--enable-filepro' '--enable-dbase' '--enable-ctype' '--disable-debug' '--enable-force-cgi-redirect' '--enable-discard-path' '--enable-sigchild' '--enable-gd-imgstrttf' '--with-openssl' '--with-apxs=/usr/sbin/apxs' 'i386-suse-linux' '--with-pgsql=/usr/local/pgsql' The given error message when i tried to start apache: Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined symbol: PQescapeBytea Other: same config-line WITHOUT pgsql works perfectly. -- Edit bug report at http://bugs.php.net/?id=25251&edit=1 -- Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=25251&r=trysnapshot4 Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=25251&r=trysnapshot5 Fixed in CVS: http://bugs.php.net/fix.php?id=25251&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=25251&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=25251&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=25251&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=25251&r=support Expected behavior: http://bugs.php.net/fix.php?id=25251&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=25251&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=25251&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=25251&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=25251&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=25251&r=dst IIS Stability: http://bugs.php.net/fix.php?id=25251&r=isapi Install GNU Sed: http://bugs.php.net/fix.php?id=25251&r=gnused

« previous php.bugs (#46674) next »