#25251 [Com]: starting apache after compile with postgres fails!

From: Date: Tue, 26 Aug 2003 13:27:21 +0000
Subject: #25251 [Com]: starting apache after compile with postgres fails!
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-46682@lists.php.net to get a copy of this message
ID: 25251 Comment by: necmon_ at gmx dot de Reported By: necmon at gmx dot de Status: Feedback Bug Type: Compile Failure Operating System: Suse Linux 7.2 PHP Version: 4.3.3 New Comment: [forgot my password, uhm, and i don't receive an email with it...] I'm using postgresql 7.3.4 - I'm using always the latest stable version, that's why I was recompiling php. Previous Comments: ------------------------------------------------------------------------ [2003-08-26 07:17:58] iliaa@php.net Which version of PostgreSQL are you using? ------------------------------------------------------------------------ [2003-08-26 07:06:36] necmon at gmx dot de Description: ------------ my configure line: './configure' '--bindir=/usr/bin' '--libdir=/usr/lib' '--with-config-file-path=/etc' '--with-exec-dir=%{libdir}/php/bin' '--with-gd=yes' '--with-tiff-dir=/usr' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-pdflib=/usr' '--with-ldap=yes' '--with-zlib=yes' '--with-bz2' '--with-ttf' '--with-xml=no' '--with-t1lib' '--with-sablot' '--with-readline' '--with-ftp' '--with-ndbm' '--with-gdbm' '--with-mcrypt' '--with-gettext' '--with-mm' '--with-gd=yes' '--enable-versioning' '--enable-yp' '--enable-bcmath' '--enable-trans-sid' '--enable-inline-optimization' '--enable-track-vars' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-shmop' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-memory-limit' '--enable-filepro' '--enable-dbase' '--enable-ctype' '--disable-debug' '--enable-force-cgi-redirect' '--enable-discard-path' '--enable-sigchild' '--enable-gd-imgstrttf' '--with-openssl' '--with-apxs=/usr/sbin/apxs' 'i386-suse-linux' '--with-pgsql=/usr/local/pgsql' The given error message when i tried to start apache: Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined symbol: PQescapeBytea Other: same config-line WITHOUT pgsql works perfectly. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=25251&edit=1

« previous php.bugs (#46682) next »