#25337 [NEW]: Apache (1.3.27) with dom support doesn't start
From: spunge at spunge dot org
Operating system: Linux
PHP version: 4.3.3
PHP Bug Type: Reproducible crash
Bug description: Apache (1.3.27) with dom support doesn't start
Description:
------------
When compliling PHP with dom support, Apache will not start, but also
produces no errors (it creates a zero length error_log). Compiling PHP as
a static module seems to work at this point though. Removing --with-dom
seems to make this issue go away.
Reproduce code:
---------------
No PHP code needed
Actual result:
--------------
This GDB was configured as "i386-redhat-linux"...
(gdb) run -X
Starting program: /usr/local/apache/test/bin/./httpd -X
Program received signal SIGSEGV, Segmentation fault.
__pthread_mutex_lock (mutex=0x80de40c) at mutex.c:91
mutex.c:91: No such file or directory.
--
Edit bug report at http://bugs.php.net/?id=25337&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=25337&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=25337&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=25337&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=25337&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=25337&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=25337&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=25337&r=support
Expected behavior: http://bugs.php.net/fix.php?id=25337&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=25337&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=25337&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=25337&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=25337&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=25337&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=25337&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=25337&r=gnused
Thread (9 messages)
- spunge at spunge dot org