#26844 [Opn->Fbk]: Problems with --with-mime-magic
| From: | sniper@php.net | Date: | Tue, 13 Jan 2004 19:34:08 +0000 |
| Subject: | #26844 [Opn->Fbk]: Problems with --with-mime-magic | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-53272@lists.php.net to get a copy of this message | ||
ID: 26844
Updated by: sniper@php.net
Reported By: php at humbapa dot ch
-Status: Open
+Status: Feedback
Bug Type: PHP options/info functions
Operating System: Linux 2.4.22 (Debian unstable)
PHP Version: 5CVS-2004-01-08 (dev)
New Comment:
So PHP 4 CVS works, but PHP 5 doesn't?
Previous Comments:
------------------------------------------------------------------------
[2004-01-09 03:25:02] php at humbapa dot ch
With the latest PHP4.3.* from CVS
--with-mime-magic=/usr/local/apache2/conf/magic works without any
problems
------------------------------------------------------------------------
[2004-01-08 09:00:05] php at humbapa dot ch
Description:
------------
When I start apache2 with php5cvs as SAPI module the error_log
contains:
PHP Warning: PHP Startup: : (/usr/local/apache2/conf/magic:22) '' is
not a valid mimetype, etry skipped in Unknown on line 0
PHP Warning: PHP Startup: : (/usr/local/apache2/conf/magic:59)
'audio/x-aiff ' is not a valid mimetype, etry skipped in Unknown on
line 0
PHP Warning: PHP Startup: : (/usr/local/apache2/conf/magic:270)
'text/plain 8bit' is not a valid mimetype, etry skipped in Unknown
on line 0
I use the latest PHP5 from CVS and build with:
--with-mime-magic=/usr/local/apache2/conf/magic (the magicfile that
comes with apache2)
- is it not possible to use the magicfile from apache2?
- why do the startuperros show up when I set display_startup_errors =
Off in php.ini?
- Apache2 exit with segmentation fault when I call the function
phpinfo()
- etry should be entry :-)
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=26844&edit=1