#26844 [Opn->Fbk]: Problems with ext/mime_magic
| From: | sniper@php.net | Date: | Wed, 14 Jan 2004 15:45:37 +0000 |
| Subject: | #26844 [Opn->Fbk]: Problems with ext/mime_magic | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-53311@lists.php.net to get a copy of this message | ||
ID: 26844
Updated by: sniper@php.net
Reported By: php at humbapa dot ch
-Status: Open
+Status: Feedback
Bug Type: *General Issues
Operating System: Linux 2.4.22 (Debian unstable)
PHP Version: 5CVS-2004-01-08 (dev)
New Comment:
Exactly what errors do you get? (and DO enable the
display_startup_errors!!)
Previous Comments:
------------------------------------------------------------------------
[2004-01-14 04:00:40] php at humbapa dot ch
PHP5.0.0RC1-dev
php.ini:
display_startup_errors = Off
mime_magic.debug = 1
the startuperrors are still shown at startup
phpinfo() shows (this time without seg fault):
mime_magic support => invalid magic file, disabled
Directive => Local Value => Master Value
mime_magic.debug => 1 => 1
mime_magic.magicfile => /usr/local/apache2/conf/magic =>
/usr/local/apache2/conf/magic
there is no problem with PHP4
I think there is something wrong with the magic-file parser in PHP5
(the same file works with PHP4)
------------------------------------------------------------------------
[2004-01-13 14:38:21] sniper@php.net
There's new php.ini option, mime_magic.debug, try enable that in your
php.ini. (add line 'mime_magic.debug = 1' in it)
------------------------------------------------------------------------
[2004-01-13 14:34:07] sniper@php.net
So PHP 4 CVS works, but PHP 5 doesn't?
------------------------------------------------------------------------
[2004-01-09 03:25:02] php at humbapa dot ch
With the latest PHP4.3.* from CVS
--with-mime-magic=/usr/local/apache2/conf/magic works without any
problems
------------------------------------------------------------------------
[2004-01-08 09:00:05] php at humbapa dot ch
Description:
------------
When I start apache2 with php5cvs as SAPI module the error_log
contains:
PHP Warning: PHP Startup: : (/usr/local/apache2/conf/magic:22) '' is
not a valid mimetype, etry skipped in Unknown on line 0
PHP Warning: PHP Startup: : (/usr/local/apache2/conf/magic:59)
'audio/x-aiff ' is not a valid mimetype, etry skipped in Unknown on
line 0
PHP Warning: PHP Startup: : (/usr/local/apache2/conf/magic:270)
'text/plain 8bit' is not a valid mimetype, etry skipped in Unknown
on line 0
I use the latest PHP5 from CVS and build with:
--with-mime-magic=/usr/local/apache2/conf/magic (the magicfile that
comes with apache2)
- is it not possible to use the magicfile from apache2?
- why do the startuperros show up when I set display_startup_errors =
Off in php.ini?
- Apache2 exit with segmentation fault when I call the function
phpinfo()
- etry should be entry :-)
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=26844&edit=1