#27096 [NEW]: session_start(): Failed to initialize storage module
| From: | ak at epsilon7 dot gr | Date: | Fri, 30 Jan 2004 12:55:43 +0000 |
| Subject: | #27096 [NEW]: session_start(): Failed to initialize storage module | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-54180@lists.php.net to get a copy of this message | ||
From: ak at epsilon7 dot gr
Operating system: Redhat 9
PHP version: 4.3.4
PHP Bug Type: Session related
Bug description: session_start(): Failed to initialize storage module
Description:
------------
É have installed SquirrelMail on a clean machine
running RedHat Linux 9.
The following msg constantly appears
Fatal error: session_start(): Failed to initialize storage module
Reproduced the same result even with a simple script:
<?php
session_start();
?>
I am using Apache/2.0.47 (Red Hat Linux)
php.ini :
--------------------------------------------
[Session]
session.save_handler = user
session.save_path = /tmp/.phpsess
session.name = BAID
session.auto_start = 0
session.cookie_lifetime = 0
session.serialize_handler = php
session.gc_probability = 100
session.gc_maxlifetime = 1440
session.entropy_length = 0
session.use_cookies = 1
session.cookie_path = /
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
Configure Command:
--------------------------------------------
'./configure' '--with-apxs2=/usr/sbin/apxs' '--enable-shared'
'--enable-calendar' '--enable-bcmath' '--enable-dbase'
'--enable-filepro'
'--enable-sysvsem' '--enable-sysvshm' '--enable-inline-optimization'
'--enable-track-vars' '--enable-sigchild' '--enable-ftp'
'--enable-gd-imgstrttf' '--enable-gd-imgstrttf' '--with-openssl'
'--with-iconv' '--with-expat' '--enable-xslt'
'--with-xslt-sablot'
'--with-sablot-js' '--with-imap=shared' '--with-kerberos'
'--with-imap-ssl' '--with-gettext=shared' '--with-mysql=shared'
'--with-zlib=shared' '--with-gd=shared,/usr/local/php/gd' '--with-ttf'
'--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-dom=shared'
'--with-dom-xslt' '--with-curl=shared'
'--with-ming=shared,/usr/local/php/ming'
Reproduce code:
---------------
<?php
session_start();
?>
Expected result:
----------------
The page to load with no errors.
Actual result:
--------------
Fatal error: session_start(): Failed to initialize storage module. in
/var/www/html/test.php on line 3
--
Edit bug report at http://bugs.php.net/?id=27096&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=27096&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=27096&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=27096&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=27096&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=27096&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=27096&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=27096&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=27096&r=support
Expected behavior: http://bugs.php.net/fix.php?id=27096&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=27096&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=27096&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=27096&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=27096&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=27096&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=27096&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=27096&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=27096&r=float