#27170 [NEW]: php5 fails to recognize extension modules
| From: | true_idler at hotmail dot com | Date: | Fri, 06 Feb 2004 23:41:42 +0000 |
| Subject: | #27170 [NEW]: php5 fails to recognize extension modules | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-54525@lists.php.net to get a copy of this message | ||
From: true_idler at hotmail dot com
Operating system: Windows XP
PHP version: 5.0.0b3 (beta3)
PHP Bug Type: Dynamic loading
Bug description: php5 fails to recognize extension modules
Description:
------------
Despite copying both the php_mysql.dll and libMySQL.dll files to every
possible location I could think of that would fix the problem(Systemroot,
Windows\system32, PHP DLLS directory, PHP Extensions directory, PHP Root
directory) and editting my php.ini file's extension_dir accordingly, php,
on startup, still fails to load the php_mysql.dll with a "specified
procedure could not be found."
I have checked the manual a number of times, which simply states to modify
the php.ini file to enable the extension(and to set the extension_dir) and
copy the libMySQL.dll file into the systemroot directory. Following those
guidelines, PHP still fails on startup.
--
Edit bug report at http://bugs.php.net/?id=27170&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=27170&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=27170&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=27170&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=27170&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=27170&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=27170&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=27170&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=27170&r=support
Expected behavior: http://bugs.php.net/fix.php?id=27170&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=27170&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=27170&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=27170&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=27170&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=27170&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=27170&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=27170&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=27170&r=float