ID: 27201
Updated by: iliaa@php.net
Reported By: lars at erhardsen dot dk
-Status: Open
+Status: Feedback
Bug Type: Program Execution
Operating System: debian woody
PHP Version: 4.3.4
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
The apache2 build bug has been fixed.
As far as the exec() situations I've just tried to
replicate the bug with the while() example and was unable
to do so.
Previous Comments:
------------------------------------------------------------------------
[2004-02-11 08:17:09] lars at erhardsen dot dk
Now this appears in the apache error-log:
sh: /hostname: No such file or directory
sh: /uptime: No such file or directory
How can this be?
------------------------------------------------------------------------
[2004-02-11 02:53:24] derick@php.net
If you want it stable, use 1.3.29, setting it to feedback to see if it
works with apache 1.3.
Derick
------------------------------------------------------------------------
[2004-02-11 01:55:01] lars at erhardsen dot dk
Sorry, the last posting was a little un-informative.
I tried compiling the cvs snapshot as cli, and set up a program loop
with the contents stated in my previous posting. I let it run to around
5000, and no error appeared.
I compiled the cli executeable with "./configure --disable-all
--disable-cgi --enable-debug".
I then tried to compile the source with --with-apxs2=path - which ended
up with the following error:
/home/admin/debug/php4-STABLE-200402101230/sapi/apache2handler/sapi_apache2.c:
In function `php_apache_request_ctor':
/debug/php4-STABLE-200402101230/sapi/apache2handler/sapi_apache2.c:432:
`f' undeclared (first use in this function)
/debug/php4-STABLE-200402101230/sapi/apache2handler/sapi_apache2.c:432:
(Each undeclared identifier is reported only once
/debug/php4-STABLE-200402101230/sapi/apache2handler/sapi_apache2.c:432:
for each function it appears in.)
I'm currently considering to replace Apache2 with Apache 1.3.xx - to
see, if it could help.
------------------------------------------------------------------------
[2004-02-10 17:56:43] sniper@php.net
Can you produce the problem with 4.3.4 CLI binary?
What apache2 error? Compile time? or what??
------------------------------------------------------------------------
[2004-02-10 08:56:16] lars at erhardsen dot dk
With the new source, and the following code, I cannot reproduce the
error.
My concern is now, that it is caused by apache2 - but the strange thing
is, that on the slow machine, this error doesn't occur.
The apache2handler seems broken( or maybe I cannot compile it - error
40 ;o)) so I cannot check it with the apache server...
The code:
<?
$i = 0;
while ($i < 10000) {
echo $i . ": ";
system ( "hostname" );
echo " | ";
$a = exec ( "uptime" );
$b = split(',', $a);
$c = split('up', $b[0]);
$d = split(':', $b[3]);
echo $c[1] . " | " . $d[1] . ", " . $b[4] . ", " . $b[5];
echo "\r\n";
$i++;
}
?>
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/27201
--
Edit this bug report at http://bugs.php.net/?id=27201&edit=1