#27250 [Fbk->Opn]: PHP Extensions cause apache load failure
ID: 27250
User updated by: 0zone at pixelcarnage dot com
Reported By: 0zone at pixelcarnage dot com
-Status: Feedback
+Status: Open
Bug Type: Apache related
Operating System: Windows 2000
PHP Version: 5.0.0b4 (beta4)
New Comment:
Still doesn't work using the snapshot, will use beta 3 untill a stable
release comes out.
Previous Comments:
------------------------------------------------------------------------
[2004-02-15 05:57:15] dont at want dot com
sorry, but the latest php snap shot didn't work eiter. Apache starts
but if you try to load an extension Apache didn't start with the error
: 1067 from the OS.
------------------------------------------------------------------------
[2004-02-14 10:51:47] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5-win32-latest.zip
Remove ALL old PHP related dlls first! (php5ts.dll is most important)
------------------------------------------------------------------------
[2004-02-14 02:13:13] 0zone at pixelcarnage dot com
Description:
------------
I installed beta 4 today, put all the files in the correct places,
changed the apache(1.3.28) config for php5 and tried to start apache,
it worked, but mysql wasn't enables so I configured the php.ini file to
include the extension. After I saved I tried to start apache again,
only it fails before it even writes anything to the logs, this is the
message:
The instruction at "0z007ec44d" referenced memory at "0x0110c000". The
memory could not be "read".
I turned the extension off and apache works again, I then tried to use
the sockets extension, this fails with the same error.
So if I try and load a php extension apache crashes. PHP itself loads
fine with any extension.
The only line I changed in the config file was to point the temp folder
to C:/web/tmp/ instead of /tmp/, and to enable a few extensions.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27250&edit=1
Thread (6 messages)