#27250 [Com]: PHP Extensions cause apache load failure
| From: | hauser at pandora dot be | Date: | Sat, 21 Feb 2004 00:17:57 +0000 |
| Subject: | #27250 [Com]: PHP Extensions cause apache load failure | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-55257@lists.php.net to get a copy of this message | ||
ID: 27250
Comment by: hauser at pandora dot be
Reported By: 0zone at pixelcarnage dot com
Status: Bogus
Bug Type: Apache related
Operating System: Windows 2000
PHP Version: 5.0.0b4 (beta4)
New Comment:
BETA 4 does not work correctly. I'm having the same problems on a Win
XP box.
I have done dozens of php installs, so i know the process inside out,
so please spare me the "remove ALL dll's comment;)
I even installed the latest Apache, however, the error log is empty. So
i viewed the even viewer, and got this:
The Apache service named Apache.exe reported the following error:
>>> in Unknown on line 0 <<<
before the error.log file could be opened.
More information may be available in the error.log file. .
Previous Comments:
------------------------------------------------------------------------
[2004-02-15 23:20:40] sniper@php.net
Beta4 works fine as long as you install it and ALL of it's dlls
correctly.
------------------------------------------------------------------------
[2004-02-15 19:52:39] 0zone at pixelcarnage dot com
Still doesn't work using the snapshot, will use beta 3 untill a stable
release comes out.
------------------------------------------------------------------------
[2004-02-15 05:57:15] dont at want dot com
sorry, but the latest php snap shot didn't work eiter. Apache starts
but if you try to load an extension Apache didn't start with the error
: 1067 from the OS.
------------------------------------------------------------------------
[2004-02-14 10:51:47] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5-win32-latest.zip
Remove ALL old PHP related dlls first! (php5ts.dll is most important)
------------------------------------------------------------------------
[2004-02-14 02:13:13] 0zone at pixelcarnage dot com
Description:
------------
I installed beta 4 today, put all the files in the correct places,
changed the apache(1.3.28) config for php5 and tried to start apache,
it worked, but mysql wasn't enables so I configured the php.ini file to
include the extension. After I saved I tried to start apache again,
only it fails before it even writes anything to the logs, this is the
message:
The instruction at "0z007ec44d" referenced memory at "0x0110c000". The
memory could not be "read".
I turned the extension off and apache works again, I then tried to use
the sockets extension, this fails with the same error.
So if I try and load a php extension apache crashes. PHP itself loads
fine with any extension.
The only line I changed in the config file was to point the temp folder
to C:/web/tmp/ instead of /tmp/, and to enable a few extensions.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27250&edit=1