#27248 [Fbk->Opn]: php_exif.dll crashes php

From: Date: Tue, 17 Feb 2004 20:20:30 +0000
Subject: #27248 [Fbk->Opn]: php_exif.dll crashes php
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-55085@lists.php.net to get a copy of this message
 ID:               27248
 User updated by:  zeger at zeger dot nl
 Reported By:      zeger at zeger dot nl
-Status:           Feedback
+Status:           Open
 Bug Type:         Reproducible crash
 Operating System: Windows 2k3 Server
 PHP Version:      5CVS-2004-02-14
 New Comment:

php-cgi.exe works!

php.ini excerpt :

extension=php_mbstring.dll
extension=php_exif.dll

So I guess loading php_mbstring has to be done prior to loading
php_exif.


Previous Comments:
------------------------------------------------------------------------

[2004-02-17 14:06:30] wez@php.net

Please try this:

php.ini:
extension=php_mbstring.dll
extension=php_exif.dll

NOTE: the order is important.

If that doesn't work, try modifying your PATH to
include the PHP extension dir, then try again.



------------------------------------------------------------------------

[2004-02-17 06:46:57] zeger at zeger dot nl

After some further experiments using PHP 5.0.0 snapshots in the command
prompt.

Loading php_exif.dll results in an error "php_mbstring.dll was not
found". Loading php_mbstring.dll works just fine. Loading both
php_exif.dll and mbstring.dll results in "php_mbstring.dll was  not
found".

Next, copying the php_mbstring.dll to the php.exe root results in a php
crash when loading php_exif.dll.

------------------------------------------------------------------------

[2004-02-17 05:10:11] mastabog at hotmail dot com

I can confirm this bug.

I'm downloading the php5-win32-latest.zip daily and use it with
apache1.3 and apache2.

Since the release of beta 3, all versions were always crashing while
loading the php_exif.dll (even if php_mbstring.dll was also loaded)
unless php_exif.dll was copied in the php5apache.dll directory (in my
case the php5 dir).

------------------------------------------------------------------------

[2004-02-17 04:09:03] ian_germany at hotmail dot com

Yes, mbstring is added. Without php_exif all is fine. 

If I dont have php_exif.dll in the root of the php folder php appears
unable to find it, even though it is with all the other extensions and
can find them.

this is the error I get :

This application has failed to start because php_mbstring.dll was not
found. Re-installing the application may fix this problem.

followed by:

PHP Startup:Unable to load dynamic library 'c:/php/ext/php_exif.dll' -
The specified module could not be found.

------------------------------------------------------------------------

[2004-02-16 14:17:23] helly@php.net

Are you using mbstring extension? If not load it and try again.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/27248

-- 
Edit this bug report at http://bugs.php.net/?id=27248&edit=1


Thread (15 messages)

« previous php.bugs (#55085) next »