#27321 [Fbk->Bgs]: open_basedir setting leaking between vhosts
| From: | sniper@php.net | Date: | Tue, 24 Feb 2004 22:12:13 +0000 |
| Subject: | #27321 [Fbk->Bgs]: open_basedir setting leaking between vhosts | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-55494@lists.php.net to get a copy of this message | ||
ID: 27321
Updated by: sniper@php.net
Reported By: jg at execulink dot com
-Status: Feedback
+Status: Bogus
Bug Type: Apache related
Operating System: Redhat Linux 7.3
PHP Version: 4.3.5RC3
New Comment:
This is some configuration failure on user's side:
File(/usr/ppp/p/pookie/public_html/index.php) is not within the allowed
path(s): (/usr/ppp/p/pdipietro) in Unknown on line 0
(this is perfectly valid and expected error when you try to access file
outside the open_basedir..)
Previous Comments:
------------------------------------------------------------------------
[2004-02-20 16:19:17] sniper@php.net
Read the bug #25753 once again and then give us the required
information how to reproduce this problem. (AFTER you have updated your
apache to 1.3.29 with which I can not reproduce this anymore)
------------------------------------------------------------------------
[2004-02-20 08:06:22] jg at execulink dot com
I'm using Apache/1.3.27 (Unix) (Red-Hat/Linux)
I've already tried running this snapshot:
php4-STABLE-200402191630 with no luck.
------------------------------------------------------------------------
[2004-02-20 00:25:54] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2004-02-19 15:19:05] edink@php.net
What version of apache are you using?
------------------------------------------------------------------------
[2004-02-19 13:57:04] jg at execulink dot com
Description:
------------
INI Settings, specificially open_basedir seems to be leaking between
apache virtualhost settings. Bug seems to be very similar to #25753,
but was not resolved for me in 4.3.5RC3.
e.g., One user - pookie's php fails with the following error:
(pdipietro is another user on the system, in another virtualhost).
I would really appreciate either a workaround, patch, or fix!
phpinfo(); PHP Version 4.3.5RC3
Warning: Unknown(): open_basedir restriction in effect.
File(/usr/ppp/p/pookie/public_html/index.php) is not within the
allowed
path(s): (/usr/ppp/p/pdipietro) in Unknown on line 0
Warning: Unknown(/usr/ppp/p/pookie/public_html/index.php): failed to
open stream: Operation not permitted in Unknown on line 0
Warning: (null)(): Failed opening
'/usr/ppp/p/pookie/public_html/index.php' for inclusion
(include_path='.:/usr/share/pear') in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27321&edit=1